Showing results for 
Show  only  | Search instead for 
Did you mean: 

Focus issues with rebel Ti


I just returned from a trip to South Dakota where I was taking a ton of outdoor photos and my autofocus starting going crazy on me.  I would attempt to take a shot from close in, far away, still shot, action, low light, lots of light and the camera would often churn and whirl in an attempt to focus on the subject, but would not be succesful for several seconds.  I had this issue with more than just one lens too.  I would zoom in and out and attempt to refocus on the subject and eventually it would successfully lock into the picture.  This was a pain and prevented me from getting my picture a few times (moving bison, for example).  This issue started happening some a few months ago, but was at its worse this past week.  Any ideas??



What lenses?


If it happens with multiple lenses it sounds like the camera. What focus mode are you in?


Does it happen in one shot AF with the center point the only active point?

I am in automatic focus.  both my standard lens (18-55) and zoom lens (75-300) have the issue.  Also  there was a typo in my previous post.  It is a T-3  not a Ti...(EOS 1100D).

There are at least 3 autofocus modes, and the settings for the focus point. Which are you using.

I am not really sure which mode I am using. How can I tell?


Sorry for the delay in getting back. I am in “one shot” mode

@joew55 wrote:
Sorry for the delay in getting back. I am in “one shot” mode

There are other factors to consider, too, like AF points.  


Set the camera to the Green [A] mode, go outside on a sunny day, and take some photos.  Does the issue persist?

"The right mouse button is your friend."

I am reading your posts, and can I ask a question?


My problem is the same as yours, my focusing problem started soon after taking several outdoor pictures and I cleaned my camera.  It seems the autofocus sometimes works when taking a picture of something very bright.  Works slightly better through the live screen display, but rarely if ever through the view finder.  I have tried to update software on the camera, tried different lenses, it seems the problem is with the camera body.  I have cleaned the connectors also.  Any help would be great.

It seems that your cleaning has damaged it. It is time for a replacement.
"The right mouse button is your friend."
08/18/2023: Canon EOS R5 C training series is released.

07/31/2023: New firmware updates are available.

CR-N700 - Version 1.2.0

CR-N500 - Version 1.3.0

CR-N300 - Version 1.3.0

CR-X300 - Version 1.1.0

06/30/2023: New firmware version is available for EOS-R5 C

05/31/2023: New firmware updates are available.

EOS R6 Mark II - Version 1.1.2

EOS R6 - Version 1.8.2

EOS R7 - Version 1.3.1

05/18/2023: New firmware updates are available.

EOS Rebel T100 - Version 1.1.0

EOS Rebel T7 - Version 1.2.0

EOS 5D Mark IV - Version 1.4.0

EOS 6D Mark II - Version 1.2.0

PowerShot Elph 360HS - Version

PowerShot SX420 IS - Version

PowerShot 620 HS - Version

PowerShot SX720 HS - Version

PowerShot G1X Mark III - Version

PowerShot G7X Mark II - Version

PowerShot G9X Mark II - Version


04/20/2023: New firmware version 1.4.1 is available for EOS R3

03/30/2023: New firmware updates are available.

EOS R5 - Version 1.8.1

EOS 1DX Mark III- Version 1.7.1

Speedlite EL-1 - Version 1.0.2

03/30/2023: Product Advisory for EF50 F1.2 L USM

03/30/2023: Product Advisory for EOS R10

02/24/2023: We've updated Share Your Photos

2/07/2023: New product announcements!

EOS R8 EOS R50RF-S55-210mm F5-7.1 IS STMRF24-50mm F4.5-6.3 IS STMRF15-30mm F4.5-6.3 IS STM
01/09/2023: Help ensure your autofocus is properly aligned with a Canon Precision Alignment
01/03/2023: Welcome to CES 2023!
12/08/2022: New firmware version is available for EOS C70
12/07/2022: New firmware version 1.7.0 is available for EOS R5