cancel
Showing results for 
Search instead for 
Did you mean: 

Canon EOS 1000D problem buSY

bokacbl
Contributor

Hello my frends,

I have EOS 1000D and big problem with DSLR.

Cant boot on power on. When I put fully charged battery, close batt. door, RED LED blink fast 1-2 sec and thats all. LCD display is black and stay black. When I press shutter to half or full, I can see tru viewfinder buSY message , ISO change value on light and thats all. When I put LOCKED SD Card, tru viewfinder I can see Err. , when I put  unlocked SD Card ..still buSY. Shutter have no responde

 USB to PC = not detected!

 

 

 20170810_195300.jpg

 

20170810_195335.jpg

35 REPLIES 35

Peter
Authority
There is a firmware bug with 1000D that forever will lock the camera.

I see 😞 Anyone can unbrick? JTAG, USB,... or ect. ...? Maybe bootable SD card..?

We found that often what caused this was not updating to the most recent firmware.

 

If your camera became affected by this phenomenon, while the camera was still in service life (up until 2015), our Factory Service Centers here in the United States could still manually upate the firmware. Unfortunately the camera is now out of service life, so our facilities here in the US are no longer making repairs or updates to the EOS 1000D, or Rebel XS as it is known here in the US. 

Tnx for answer! God bless you!
Actually, I'm not from the USA. I am from Bosnia and Herzegovina, Europe. Here I do not have a good service for DSLR. Is there a chance to flash a new firmware? OverSD Card or serial cable? Tank you

If your camera can be recognized by your compuer, then you should be able to update the firmware. If your camera can't be seen by the computer, then unfortunately you'll want to see if Canon in your region has options. Head to http://global.canon/en/support and select your region for support options. 

Ha. I'm going to start using the word "phenomenon" when I totally screw something up at work.  Like the curious phenomenon where it appears I do not show up, and instead I am actually at home sleeping.

 

Seems warranty or no, he should at least get loyalty credits towards a refurb or something because it didn't wear out, it is a known defect.  

Scott

Canon 5d mk 4, Canon 6D, EF 70-200mm L f/2.8 IS mk2; EF 16-35 f/2.8 L mk. III; Sigma 35mm f/1.4 "Art" EF 100mm f/2.8L Macro; EF 85mm f/1.8; EF 1.4x extender mk. 3; EF 24-105 f/4 L; EF-S 17-55mm f/2.8 IS; 3x Phottix Mitros+ speedlites

Why do so many people say "FER-tographer"? Do they take "fertographs"?

I know, it's all clear to me for a guarantee.
But ...
I am interested in how the factory enters the new firmware on a bricked board. There must be a way, rather than throwing a plate off and putting another. I wonder if anyone knows in what way they flash new firmware? Is it possible that VxWorks is forced to enter new firmware via specially formatted SD card? Or the special pins on the board that work through the serial cable? MPU is working, and its EEPROM works. It is a controller for AF, batt and SD card door, display through a viewfinder, servo, flash, buttons, shutter, ... ect. For example, when I remove a flat cable from the shutter, it reports error 99 .... That's all. It is also the primary boot, and after its boot, it should continue DIGIC III with F-ROM to boot firmware. This is the end, he has nothing to boot, or the firmware is damaged and the buSY is released. DIGIC III is the basis for LCD, photo sensor, USB, ... and that's what does not work. Not to prolong the writing, does anyone know the way to write to F-ROM that is bricked with damaged firmware? It's probably a bug that just put the firmware in the lock position.

I know, it's all clear to me for a guarantee.
But ...
I am interested in how the factory enters the new firmware on a bricked board. There must be a way, rather than throwing a plate off and putting another. I wonder if anyone knows in what way they flash new firmware? Is it possible that VxWorks is forced to enter new firmware via specially formatted SD card? Or the special pins on the board that work through the serial cable? MPU is working, and its EEPROM works. It is a controller for AF, batt and SD card door, display through a viewfinder, servo, flash, buttons, shutter, ... ect. For example, when I remove a flat cable from the shutter, it reports error 99 .... That's all. It is also the primary boot, and after its boot, it should continue DIGIC III with F-ROM to boot firmware. This is the end, he has nothing to boot, or the firmware is damaged and the buSY is released. DIGIC III is the basis for LCD, photo sensor, USB, ... and that's what does not work. Not to prolong the writing, does anyone know the way to write to F-ROM that is bricked with damaged firmware? It's probably a bug that just put the firmware in the lock position.

When a camera gets bricked like that, it's usually because the camera lost power during a firmware upgrade. Apparently there isn't enough firmware memory to install the new before removing the old, so it has to do it on the fly. If the camera loses power, the part of the firmware that boots up the camera may not be there. So there's every reason to suppose that Canon has to apply some rather heroic measures to get things working again, such as temporarily wiring in a working chip to resuscitate the one in the camera. It's not the sort of electronic surgery that you're likely to be able to do at home.

Bob
Philadelphia, Pennsylvania USA
Announcements