Showing results for 
Show  only  | Search instead for 
Did you mean: 

Brand new Canon 6D (WG) - date and time won't set


Hi there, first time user here. I purchased a brand new Canon 6D (WG) yesterday, unboxed it, charged the battery to full capacity and switched the camera on. The Date/Time/Zone setting screen appeared on the LCD and I set it accordingly, hit OK and the LCD switched itself off. However, the next time I switched the camera on, the Date/Time/Zone setting screen popped up again and the date and time had been reset to 01.01.2012 00:00:00. I tried it again, same result.


At first I thought this might be a problem with the camera's internal date/time battery. I found the following information on the Canon website: "The EOS 6D features a date/time battery that keeps the internal clock running so you don’t have to reset the date and time regularly. However, unlike the battery found in other EOS models, the EOS 6D has a rechargeable backup battery that recharges from the LP-E6 main cell and will go several months between charges. To ensure it never runs flat, make sure you turn on the EOS 6D with a fully charged LP-E6 battery for a couple of hours every few months, to keep the date/time battery fully charged."


I followed these suggestions, but still no luck. Also, I don't even have to switch the camera off or remove the main cell for the problem to occur. If I set the date and time and then navigate immediately to the date and time settings via the menu, I can see that they are not being saved at all. All of my other changes are being recorded correctly - time zone, daylight savings, day/month/year format, etc. It's just the numerical values for day, month and year, that it seems to have trouble with, which makes me think this is a bug of some sort and not a battery-related issue. In all other respects, the camera appears to be functioning correctly.


I've searched Google and various forums, but can't find anyone else who's reported the same issue. Google took me to links for Firmware updates v1.1.3 and v1.1.4 which claim to fix "a phenomenon in which the Date/Time/Zone settings screen appears on the LCD display, after the user has already configured these settings. The values for the Date/Time settings may reset if the backup functions which retain those values do not perform properly."


This sounds exactly like the issue I've been having. However, the camera came from the shop with Firmware v1.1.4 pre-installed, so besides taking the camera back and exchanging it for another, I'm at a loss for what to do. Has anyone else experienced the same issue or can offer some advice? Would it be worth trying to reinstall the firmware updates?




You need to take it back and have the sales person set the date and time.  Just in case you are missing something.   If it doesn't work properly, they can give you another one.

EOS 1DX and 1D Mk IV and less lenses then before!

Thanks for the advice. I took it back to the store and the sales person couldn't set it either so they exchanged it for another. I'm guessing the internal battery must have been a dud.