cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

5D Mark III Not Recognising CF Card in Slot 1.

Philushka
Contributor

I recently inserted a CF card into slot 1, but the camera cannot see it or format it.

 

I've tried two known, good, error free CF cards, but the camera just tells me they cannot be accessed and to change them or format them in camera.

 

I've checked for bent pins in the slot, but they seem ok from what I can see.  I contacted Canon Support who told me to revert all camera settings to factory default, which I did, but it failed to solve the issue.  Failing that they advised to have the camera checked at a Canon Service Centre.  The problem is I'm currently living and working in a country that doesn't have a service centre.  I can't afford the downtime involved in sending it to another country to be repaired, so I wondered if any other Mark III users had come across a similar issue and solved it without the need of a service centre?

 

The SD cards still work, so all is not lost, but I'd like the option to use the CF cards, particularly for high speed shooting, which they seem to handle better than SD cards.

 

Any tips, suggestions, ideas welcomed.

 

Mant Thanks

Phil

20 REPLIES 20

Philushka
Contributor

Well, Canon 'Technical Support' have been of no use.  Sadly, I'm currently in a country that doesn't have a Canon Service Centre, and having done a bit of research it seems a few other Mrk III users have had the same issue as me, all of which needed a replacement body or a repair to solve the problem.

 

Poor show Canon.  Top dollar for a 'professional' camera that can't even cope with the most basic of memory card formats.

 

Anyone recommend a reliable Nikon??

I suspect a bent pin. Unfortunately it is very difficult to see the pins at the bottom of the CF card slot. But a strong light source might let you confirm their condition definitively, something it appears you have not yet been able to do.

 

Barring the bent pin, I think you need to rely on SD cards until you're able to have the camera serviced.

 

Finally, you might feel abandoned by Canon but you have taken the camera to a location where it can not be serviced to your satisfaction. That sounds more like your choice than Canon's faliure. I am certain they would offer prompt service were you to send the camera in. At least, that has been my experience and that of others that have posted here.

 

Good luck.

Hi Cale_Kat, 

 

I've used a flashlight and magnifying glass, and as far as I can see the pins look ok.

 

I spoke to a local professional photographer who gave the address of a place that turned out to be a Canon approved repair centre here.  I've just back from there.  They said 3-4 days to investigate and hopefully repair.

 

My dissatisfaction with Canon tech support is not the lack of service centres.  I fully appreciate they can't have one in every country.  My complaint is the lack of knowledge of my problem.  I got more potential fix ideas just surfing the net than I did from Canon.  As I'm not the only person to have had this problem, the least I would have expected from the manufacturer is a list of things to try, or even a blunt but simple 'your camera needs to be returned for repair'.

 

I've never had a problem with any Canon product I've owned in the past, which is testimony to the quality of the products they produce, and I'm sure they do offer a prompt service when you're fortunate enough to be somewhere where they have a service centre, but as I travel extensively, quite often my only line of enquiry for any tech related problem is a tech support line.  In this case I just don't think Canon offered anything close to an effective level of support.

 

Anyway, I will see what the approved repair centre says when they've had chance to check it out.

 

Thanks for your reply cale_kat.  This forum is a very good source for Canon users and I appreciate your input.  If I get to find out what the issue is with my camera I will be sure to post a reply for the benefit of any other users.

 

Thanks

Phil

I'm glad you're making progress towards getting your camera repaired. The CF slot is an interface that gets too little attention for its importance, probably because it is has worked reliably for a long time. But there have been a number of posts at this forum regarding CF read errors. Sometimes it is the card and sometimes it is the camera.

 

If you are reasonably certain that the camera does not have a bent or broken pin, you might try buying/borrowing a different card for the purpose of eliminating your existing cards from the problem.  I know you wrote that the cards are known to be good and I can appreciate that my suggestion may seem wasteful of your time but while I have no idea of what caused this problem, I can surmise that if one card is "damaged" it is possible that the other card is damaged too. Heat, cold and humidity can impact memory card performance, magnetic fields can be damaging, and there are other "environmental" factors that you might have encountered.

 

It's a stretch but I'll bet one of the first things the repair center tries is a CF card of theirs to see if it works.

 

Good luck.

That's a good idea regarding the cards, but unfortunately I haven't been able to test them in another camera or get my hands on another card to try.

 

The camera is booked in for next Monday, so hopefully all will be revealed.

 

I actually prefer CF cards to SD cards.  Something about the chunky little fellows that appeals to me 🙂

 

Anyway, I'll post the findings of the service centre next week.

 

Thanks again.

Hi Philushka! I have the same problem with my 5D3. Can you please share what the service center told you? And the cost to repair? Thank you so much! Looking forward to hearing from you. 

Hi Gavin, I had the camera checked over and they said it was to do with the connection point of the CF card unit.  If it was a simple connection problem it would have been a very cheap fix, but they also suggested it might involve replacing the CF unit, which would have been more expensive and would have taken over a month to get the parts from Canon.  In the end I gave up and just used the SD slot, so the CF slot still doesn't work to this day.  Sorry I couldn't have been of more help.

Thank you for taking the time to reply back. I appreciate it! I'm currently debating whether or not to fix my CF slot. I'm just afraid of the cost (and if it's worth fixing an older camera). Since my SD slot works, I'll just follow in your footstep. Thanks again!

Towfiq5472
Apprentice
Same problem with my Mark III. I use Sandisk class 10 card. When this problem first appeared I reset all the camera settings and then it was solved but now it’s stuck. I don’t know how to solve this

should be the bend pin in your camera. I had the same problem and fix it with a tiny crew driver.

Avatar
click here to view the press release
Announcements