cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

5D Mark III - HDMI - Mirroring

shariff01
Apprentice
Hi,

I had recently upgraded to 1.3.6 and it appears that mirroring function isn’t working. I didn’t need that function before but need it now and I am unable to make it work. The camera screen goes blank and the monitor shows all the settings. Interestingly the camera options you can view full screen but when it comes to live vide it has a border around it and a AF point box that doesn’t go away and becomes larger if I go manual mode.

Also, I have tried to connect the HDMI to an HP monitor and also Elgato capture card but in both cases I get consistent 480p/59fps.I have tried to adjust all possible settings and don’t appear to be bettering 1080p/30.

I am hoping not to use ML but is that the only option to make it work on this camera? Also downgrading from 1.3.6 seems difficult and I am concerned if the camera may get bricked.
3 REPLIES 3

JustinTArthur
Apprentice

I have the same problem on a 5D Mark III running firmware 1.3.5. The HDMI output is always 480i59.94 with absolutely no mirroring despite the preference being set. I purchased a brand new Canon HTC-100 mini-HDMI cable just in case. It's the same 480i59.94 on both a BlackMagic UltraStudio Recorder 3G and a LG WebOS OLED TV.

This may have broken somewhere in the 1.3.x firmware range.

JustinTArthur
Apprentice

After downgrading to every possible firmware from 1.3.5 to 1.2.1, I found I still couldn't get more than 480i59.94 output with any display or capture card (shown on less advanced displays as 480p). Finally I took a close look at the mini-HDMI port and found that half of one of the DDC data pads is missing, and it's one that's critical for EDID negotiation. This explains why it never escalates to Full HD. I suspect it could also be why mirroring mode never activates for clean HDMI output. For anyone else having this exact problem of no FHD and no mirroring, chances are you need to replace the HDMI C port (mini-HDMI), which is unfortunately surface-mount electronics.

PXL_20220702_235530555.jpg

do you have the 1.2.1 firmware?

Avatar
click here to view the press release
Announcements