cancel
Showing results for 
Search instead for 
Did you mean: 

5D Mark II Issue with CF Cards - Cannot Format or Read

ColoScooterBob
Apprentice

Hello all.  I have a problem with my 5d Mark II.  I have recently noticed a random issue where I am unable to download images (I shoot all RAW) after a shoot even though they appear to record on the card just fine (I am able to preview each shot and cycle through images from the camera during the shoot).  However, when I get home to download the images (I download using a card reader on a Mac Pro desktop, the computer says that the card is not formated and is unreadable.  When I then put the card back in the camera, the camera states that the card is not formated and must be formated. On the past three time this happened, I was able to recover the images using a file recovery program.

 

However, yesterday's shoot went really badly.  I shot over 1,000 images on three seperate cards (two LexPro and one off brand) and all three have displayed this issue when I returned home.  For example, one of the LexPro (600x) cards now shows only a card size of 32MB as opposed to its normal 8GB size!  I cannot recover any images, cannot reformat the card nor are any images viewable through any means.  I have checked all of the pins in the camera and they appear straight with no bends or missing pins.  The issue seems to be across multiple card brands.

 

Here is my request...I would dearly love to recover these images, but at the moment that does not seem possible.  It is as if the cards have been partitioned into two blocks, one block that is only 32MB in size and the remainder of the card that I cannot get to.  Any ideas for recovering these images would be wonderful.  I shoot for non-profits, donating all of my services, and losing these images is a heartbreaker as you can guess.  I do not have a second camera as my budget will not allow it at the moment.

 

Second part of my question...what is wrong with my camera?  I have seen some posts on other forums (photography_on_the.net for example) where the issue of 5D Mark II causing some funky CF card errors has been discussed.  I am pretty certain about no bent pins, and as noted the issue is across different brands of CF card.  I typically format my cards in the camera and for a long time, this processed has worked.  However, with this latest critical error, I fear that my camera is dead and I am faced with contacting all of my non-profits and cancelling several photo shoots.

 

Any help would be greatly appreciated, both from me as well those folks that I donate services!!

8 REPLIES 8

amfoto1
Whiz

This is a tough one...

 

Since the same issue is happening with several different cards, I would first suspect your card reader. Can you try a different reader? Alternatively, can you try using the USB cable between camera and computer and see if files can be copied via that?

 

I have recently had one card that was bad (out of a batch of four I bought at the same time). This card refused to format and became unrecognized/unrecoverable after a single use, which just so happened to be when I lent it to another photographer (Canon camera, but not a 5D model). Fortunately he was shooting RAW+JPEGS and was able to copy over the JPEGs before the card crapped out completely. But nothing I've done since has been able to access anything on it. (It's a well known name brand and the other three, identical cards bought at the same time have all have worked just fine multiple times).

 

But I suspect your situation is different... since it's happening with multiple cards and different brands.

 

Also, how do you download? I'm on a PC, not a Mac, but I don't use any of the softwares for download. I simply set up a destination folder in advance, open the folder on the memory card via Explorer, then drag and drop/copy all the files into the destination folder. I don't import via Lightroom or any of the Canon softwares I've got on my computers.

 

I hope it's something easily fixed, such as a bad card reader... And not something with the camera!

Thank you for your reply!  Yup, I have tried multiple card readers as well as attempting to cable the camera directly to my mac computer.  I have also tried both a PC recovery programs as well as Mac recovery programs.  In reading through other similar posts, would it be possible that one of the pins is loose?  I would appear to be straight but may not make a reliable connect and could explain the intermittent  issue.  For the moment, I fear that the photos could be lost, but perhaps the camera is fixable?

Here is an update.  I spoke with Lexar who indicated that they would (since the card is one of the Professional 600x UDMA 7 cards) attempt to recover any images on the cards.  The turn around time for this is about 12 weeks, but worth the wait if they are able to save my work!  Canon, after describing the issue and problems, has hinted that they feel the problem may lie with my card reader (I use a Lexar UDMA reader that can read both CF and SD cards).  They recommended trying a new card reader and seeing if I can replicate the problem.  So I guess we'll try that approach first!

That's interesting...

 

The card I mentioned above having trouble with recently was a Lexar 800X UDMA 7.

 

I didn't want to name names, because I've used a lot of Lexar over the years with no problems... And three other identical cards I bought at the same time are working great. I thought it was just a fluke and they are replacing the card.

 

But it's interesting that you are having trouble, too, with a similar card.

 

I believe the camera my friend used with the memory card the first and only time before it locked up was a 40D. He told me he formatted normally and filled it with RAW + JPEGs. Later he copied the JPEGs off it onto his PC, then returned to me so I could work with the RAWs. However the card was then unreadable in either of my computers or any of my cameras.

 

***********
Alan Myers

San Jose, Calif., USA
"Walk softly and carry a big lens."
GEAR: 5DII, 7D(x2), 50D(x3), some other cameras, various lenses & accessories
FLICKR & PRINTROOM 

 





 

 

This is happening to me. Results?

Im not sure what to say about your cards or camera but I had a similar situation happen to me with my CF card while shooting a wedding. (Camera was reading Cf card err not formatted for camera) My main priority was retreiving my images. After reading several different forums, I took my card to a data recovery center. They had it for 2 weeks with no success. Then I found a company in Germany called Recoverfab that specializes in memory card recovery. I was hesitant about sending it out of the country but was willing to try anything! After receiving my CF card they emailed me the next day with all 337 images recovered! Very reasonbly priced and quick turn around!

While anything is possibile, bent or loose pins but I too believe it is your card reader, cable or Mac that is the problem.

I would concentrate there first.

 

You are using the camera to format the CF cards and not the Mac?  Yes, good.

 

You also know, when you shoot RAW files, the jpg you see on the camera is not actually the RAW file?  That means the RAW file may not be saving.  You can't view a RAW file directly without conversion some how.

 

Do you have another Canon camera that uses CF cards, swap the out.  Or perhaps, you have a bud with a Canon camera that uses CF cards.  This way you can narrow down where the problem lies.

EB
EOS 1DX and 1D Mk IV and several lenses!

Vloeg
Apprentice

If you're using a Mac...

 

I've just spent three hours trying to figure this one out. The card wouldn't be accepted by the camera because of the spotlight index folder that is automatically created after formatting.

After formatting the CF in FAT32 (MS-DOS) make sure to remove the hidden spotlight folder.

You can do that by either turning on invisible files and then ejecting the card (Do not safe eject the card!)

 

Or use this terminal command (replace Untitled with the title of your card):

$ ls -a /Volumes/Untitled

.Spotlight-V100

.Trashes

._.Trashes

.disk

.fseventsd

 

Alternatively, you can remove the folder from a Windows computer by turning on invisible files.

 

Have fun!

Announcements