cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

90D and Canon 300mm f4 L IS USM inconsistencies in exposure

Wandalynn
Enthusiast

I wanted to see if (1) anyone else has had this problem and (2) if there are any fixes. First, let me say that my Canon 300mm lens has worked perfectly on my 70D, my 6Dii, and my R cameras. Add to that that all of my other Canon lenses perform perfectly with the 90D. I almost exclusively shoot in AV mode, mostly nature closeups, and mostly use evaluative metering, sometimes spot.  Taking pictures with the 90D + 300 through the VF, almost all of them are severely underexposed, almost black. Taking pictures with same lens using Live View, the exposure is fine. Again, that never happens with my other lenses on this camera, and I have no problems with this lens on my other cameras. Input appreciated.

1 ACCEPTED SOLUTION

ebiggs1
Legend

One of three things have got to have a problem. One, the camera. Two, the lens and three, you. First reset the camera to factory. Two if the lens works perfectly fine on all your other cameras, it is probably OK. So, that leaves, you!

Hopefully the reset will correct that issue. 

 

After rest, set the mode to P mode. ISO 200, One shot, do not use Ai-servo. Put the 300mm f4L in the AF position and go outside on a nice day and try it.  Select  different subject. If it works, it works!  You need to examine if you set something incorrectly either on purpose or by accident.

EB
EOS 1DX and 1D Mk IV and several lenses!

View solution in original post

22 REPLIES 22

Waddizzle
Legend

@Wandalynn wrote:

I wanted to see if (1) anyone else has had this problem and (2) if there are any fixes. First, let me say that my Canon 300mm lens has worked perfectly on my 70D, my 6Dii, and my R cameras. Add to that that all of my other Canon lenses perform perfectly with the 90D. I almost exclusively shoot in AV mode, mostly nature closeups, and mostly use evaluative metering, sometimes spot.  Taking pictures with the 90D + 300 through the VF, almost all of them are severely underexposed, almost black. Taking pictures with same lens using Live View, the exposure is fine. Again, that never happens with my other lenses on this camera, and I have no problems with this lens on my other cameras. Input appreciated.


I agree with Ernie. The friction created by the act of mounting or dismounting a lens is sufficient to keep lens contacts clean.  If the contacts are not discolored, then there is probably nothing wrong with them.  Just make sure the have spring action.

 

If you are shooting in Av or Tv mode, then do not use ISO Auto. As a general rule, you do not want give the camera control over two legs of the Exposure Triangle.  Limit the camera to controlling just one leg, or none of them.

 

Resetting the camera is good idea.  You should be able to see the exposure metering in the viewfinder, even if it is under exposed.  Make sure you do not have Exposure Compensation dialed in.  Make sure your thumb is not accidentally locking exposure as you carry and hold the camera.

 

I do not advise using Spot Metering handheld.  Tripod, yes.  Handheld, inadvisable.  Spot metering is a little too exact at times.  Be aware that Spot Metering only [meters] with the Center AF point!  I have used Center Weighted Averaging in conjunction with the Center AF point in One Shot mode with pretty good success at nailing the exposure of the subject.

 

Perhaps there is some quirk with the EF 300mm f/4L IS USM and the 90D.  Yours is the first complaint that I have heard.

--------------------------------------------------------
"The right mouse button is your friend."

"If you are shooting in Av or Tv mode, then do not use ISO Auto. As a general rule, you do not want give the camera control over two legs of the Exposure Triangle."

 

Smiley Happy Spot on!  I am not sure how the camera decides which auto function has top priority but it is a situation to avoid.

If you KNOW your settings it is probably better than letting the camera pick one for you. However most current DSLRs are very good at it.

EB
EOS 1DX and 1D Mk IV and several lenses!

Thank you for your suggestions and the info on spot metering. I am guilty of using Auto ISO with AV but also frequently set the ISO.

Announcements
01/18/2023: New firmware version 1.1.1 is available for EOS R6 Mark II
01/09/2023: Help ensure your autofocus is properly aligned with a Canon Precision Alignment
01/03/2023: Welcome to CES 2023!
12/08/2022: New firmware version 1.0.5.1 is available for EOS C70
12/07/2022: New firmware version 1.7.0 is available for EOS R5
12/07/2022: New firmware version 1.7.0 is available for EOS R6
11/22/2022: New firmware available for EOS R3, EOS R7 and EOS R10
11/16/2022: We're thrilled to be ranked among the Best Employers for Veterans in 2022 by Forbes.
08/31/2022: New firmware version 1.1.1 is available for RF 70-200mm L IS USM
08/09/2022: New firmware version 1.2.0 is available for CR-N 300
08/09/2022: New firmware version 1.2.0 is available for CR-N 500
07/14/2022: New firmware version 1.0.1 is available for CR-X300
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version 1.0.5.1 is available for EOS-C500 Mark II
05/26/2022: New firmware version 1.0.3.1 is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version 1.0.1.1 is available for EOS R5 C
03/23/2022: New firmware version 1.0.3.1 is available for EOS-C70
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/19/2022: READY FOR ANYTHING EOS-R5 C
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.