cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

CP900 fails to boot (shows Canon screen but never progresses)

dogldogl
Apprentice

Even after disconnecting power for 24hrs, when powering on my CP900 shows the Canon screen but never progresses past that state. Is there a way to hard-factory-reset at power-on ?

Any other ideas or solutions to revive it?

2 REPLIES 2

phoenix8
Contributor

I have/had the same problem. Called support to no avail. They offered a small discount on a newer model. I have built a few computers in my lifetime. The problem is that the printer was not used for a long time. There must be a battery or a diode on the control board. I had my plugged in for over 24 hours and then I did the reset procedure. That is unplug the printer and press the power button 5 times, wait a few minutes and then plug it back in and power it on. Just doing the reset procedure sometimes works, but if it does not as I said, leave it plugged in for a long time.

phoenix8
Contributor
I have/had the same problem. Called support to no avail. They offered a small discount on a newer model. I have built a few computers in my lifetime. The problem is that the printer was not used for a long time. There must be a battery or a diode on the control board. I had my plugged in for over 24 hours and then I did the reset procedure. That is unplug the printer and press the power button 5 times, wait a few minutes and then plug it back in and power it on. Just doing the reset procedure sometimes works, but if it does not as I said, leave it plugged in for a long time.
Avatar
click here to view the press release
Announcements