cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

DPP4 Depth Compositing tool (Focus Stacking) - Error Message Confusion

LBK
Apprentice

So, I'm trying Depth Compositing for the first time and running into some frustration. 

 

I am using an RP with the 24-105 lens, both are compatible with focus stacking.  I have DPP 4.13.10.

 

I have enabled focus bracketing and created a separate folder in camera.  I take the shot and the RP takes 20 photos with different focus, as I've set it to do.  I am shooting .jpg in medium size. 

 

The images open in DPP 4.  I have tried both clicking on one image, and selecting all images in the range. Either way, I start the Depth Compositing tool and it begins to run.  However, it gives me an error message for each image and no compositing occurs.

 

Any thoughts?

 

 

 

Screen Shot 2020-12-12 at 1.20.27 PM.png

9 REPLIES 9

Waddizzle
Legend

Why are you using medium size JPG files?  Try using full size, highest resolution files.  If it accepts RAW, then shoot RAW.

--------------------------------------------------------
"The right mouse button is your friend."

Nope.  Did it with RAW too.

 

Screen Shot 2020-12-12 at 2.58.55 PM.png

I am experiencing the same problem. I talked to someone in canon technical support yesterday but he was not able to duplicate the problem. I used depth compositing a couple of months ago and everything worked fine. Since I had updated Digital Photo Professional to 4.13, i tried installing an earlier version but still ran into problems. I uninstalled DDP4 and reinstalled the new version and am having the same problem.

I did some experimenting today and found that Depth Compositing seems to fail during low light conditions. When I used images with more light the process worked.

I was using AE exposure so the exposures are determined by the camera and "normal" in appearance so not sure how this would factor in.

 

Thanks for the tip.   That was my problem.  I intentionally underexposed a white flower, intending to correct it in DPP.   I couldn't get the depth compositing to work.   Adjusted the exposure and shot it again, and it worked!

DougFraser
Contributor

I'm having the same problem. I get an error for every image when attempting to do depth composing. At a loss as to what to do. Maybe I need to use RAW instead of cRAW?

Tried again with RAW file and had the same problem - an error for every file ("skipped")

ER-M
Apprentice

I may have a solution for you.  I've spent the last day trying to resolve the same problem with my Canon M 6 Mark ii which has similar Focus Bracketing capabilities.  I could not get the latest DPP4 Depth Compositing software to work on my photo set taken with an EF 100mm f2.8L MACRO IS USM lens, which is specifically approved for this application in the DPP4 Instruction Manual, BUT which needs to be attached to the camera with an EF-EOS M mount adaptor. (I used the Canon mount adaptaor which came with my kit.)  I tried different file types, focus types, everything mentioned here and everything I could think of.  FINALLY, I switched to my EF-M 18-150 lens, turned it to 100 mm and took the same subject with the same settings and focus bracketing settings.  IT WORKED!  The DPP4 Depth Compositing software was able to compile the photo.  I can't say for certain that the problem is use of the adaptor though I suspect it is.  However, my 100mm MACRO lens is at least 10 years old, so even though it has the same name as the current versions, it may not have the same electronic capabilities.  So, I would suggest trying a lens that is native to your camera.

Announcements
01/18/2023: New firmware version 1.1.1 is available for EOS R6 Mark II
01/09/2023: Help ensure your autofocus is properly aligned with a Canon Precision Alignment
01/03/2023: Welcome to CES 2023!
12/08/2022: New firmware version 1.0.5.1 is available for EOS C70
12/07/2022: New firmware version 1.7.0 is available for EOS R5
12/07/2022: New firmware version 1.7.0 is available for EOS R6
11/22/2022: New firmware available for EOS R3, EOS R7 and EOS R10
11/16/2022: We're thrilled to be ranked among the Best Employers for Veterans in 2022 by Forbes.
08/31/2022: New firmware version 1.1.1 is available for RF 70-200mm L IS USM
08/09/2022: New firmware version 1.2.0 is available for CR-N 300
08/09/2022: New firmware version 1.2.0 is available for CR-N 500
07/14/2022: New firmware version 1.0.1 is available for CR-X300
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version 1.0.5.1 is available for EOS-C500 Mark II
05/26/2022: New firmware version 1.0.3.1 is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version 1.0.1.1 is available for EOS R5 C
03/23/2022: New firmware version 1.0.3.1 is available for EOS-C70
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/19/2022: READY FOR ANYTHING EOS-R5 C
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.