Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon Connect App and iOS 16 issue??


Anyone having issues with connecting their camera to the Canon Connect app after upgrading to iOS 16?  I am not able to connect at home or out in the field.  I've been able to connect in the past, prior to Apple's release of iOS 16.



Seconded. Since iOS 16, camera connect simply does not work most of the time. You can initiate from the camera to create the hotspot, but the app doesn’t recognize the hotspot. You can initiate from the app, but the phone won’t join the camera hotspot (or the camera doesn’t create it).

I was able to connect a single time by resetting the communication settings and unpairing the phone. However, it doesn’t work the second time. 


I just upgraded my R6's firmware to 1.60 from 1.52 and then I could immediately pair with my iPhone 14 Pro Max running iOS 16.0.1.

Yes - that works, but after upgrading to IOS 16.1.1 it fails

I’m on 16.1.1 as well and it’s still working for me. I might have had to do a reconnect recently but am not sure.


I have a T7i that worked fine with the earlier IOS version. I would connect the iPad Wi-Fi to the camera wireless by pressing the camera wireless button, then select the iPad to connect to the camera. With the new version of  Camera Connect, this rarely worked, and I would get an immediate connection failure. This is what I did to fix the situation with both IOS 16.2 and Cannon Connect version build 1331.

1. It seems to be essential that Bluetooth be paired correctly to the iPad. I had to blow away the old setting and re-pair the camera with the iPad.

2. Set the camera wireless communication settings to Wi-Fi - Enable and NFC - Enable. Both seem to be important. If NFC is not set to enable, the Camera Connect software won't work properly.

3. Not sure if this is required, but I updated my camera firmware to version 1.1.0.

4. Be sure the camera Bluetooth function is set to Smartphone. This is part of the pairing process.

5. Open the Camera Connect app on the iPad. Both the Bluetooth and the Wifi icons were grayed out.

6. Turn on the camera, if not already on. In a few seconds, the app recognized the camera and the bluetooth symbol was no longer grayed out. On the camera display, the bluetooth symbol was showing but the wireless icon was set to "off".

All the problems I was having were fixed by having the iPad bluetooth paired to the camera and turned on. What seems to be happening is that bluetooth handles the wireless portion of the network connection. If I press the wireless button on the camera, everything goes south. Maybe only the bluetooth option works with this version of the software, but I don't know for sure. At least the picture import function works well. I don't remember if I had to make any other settings on the Canon app, Right now, if the app is on, it will automatically recognize the camera nearly as soon as I turn on the camera.  Hope this helps.

Enter for a chance to win