Canon Community Canon Community

New Contributor
Posts: 1
Registered: ‎10-02-2016

Re: EOS Utility not working with Windows 10

[ Edited ]

I have read through all of the concerns people have had and mine is almost identical.  I uploaded pictures on Friday night; computer received updates on Saturday morning; will not read camera.  I followed the advice from many of you but when I go to Canon support, it says there are no drivers or updates for EOS Utility 2 (which I uploaded last year when WIN 10 arrived).  Also, when I try to run EOS Utility (previous version) it controls my Pandora stations.  I find that very strange.  Any new advice or workable solutions?

New Contributor
Posts: 1
Registered: ‎01-09-2017

Re: EOS Utility not working with Windows 10

I have just upgraded to Windows 10 and I have read the previous posts about downloading the EOS ulitlity driver for Window's 8.1, but I cannot do that because I don't have a previous EOS Utility. I don't know where the disc that came with my camera orginally, and now I can't get my pictures uploaded. Is there anyone that can help me download the EOS utility for my Canon Digital Rebal XT so I can do the windos 8.1 upgrade and get my 250 pictures uploaded, so I can take more pictures? 


I'm very frusterated and don't know what else to do!

Thanks in advance

Occasional Contributor
Posts: 10
Registered: ‎08-03-2015

Re: EOS Utility not working with Windows 10

Honored Contributor
Posts: 6,372
Registered: ‎08-13-2015

Re: EOS Utility not working with Windows 10

If you are starting from scratch, then you will need to start at the beginning.  You will need to install the original version of the software, so that you can upgrade it.  Use this link to find your camera's support page. 


Once you click on the software link, it may automatically detect your Windows 10.  Use that drop down to select the operating system that was current when the camera was released, most likley Windows XP, I'm guessing. 


You should find a "Solutions Disk" among the operating system listings.  This is a digital copy of the original disk that would come with a new camera. 


I cannot say whether or not the packages will install properly on Windows 10, because the way software interacts with attached hardware has dramatically changed over the years.  Hopefully, it will install in a compatibility mode, which should be invisible to the user.


"I don't rent software. I use Photoshop CS6, ACR 9.8 and Lightroom 6.8 ."
New Contributor
Posts: 1
Registered: ‎01-16-2017

Re: EOS Utility not working with Windows 10

Turn off the fire wall.
That should fix it
New Contributor
Posts: 1
Registered: ‎02-11-2017

Re: EOS Utility not working with Windows 10

 It's a shame for a big company not providing working drivers for Windows 10. Every time Windows 10 updates Canon 6D gives 'USB device not recognized'. Sometimes i can download images from camera reinstalling EOS Utility, sometimes i disable or enable USB 3.0 support from BIOS.

 I use another Canon product: 5000F scanner working only with Windows 32 bits drivers !

 Thank you Canon for your support,


Posts: 1,170
Registered: ‎10-25-2012

Re: EOS Utility not working with Windows 10

Hi razvand!


Thank you for reaching out to Canon USA!


If you've updated your software to the most current version from our site HERE, and you're still having problems, we suggest reaching out to technical support. If you're in the USA, support is at 1-800-OK-CANON (800-652-2666). Outside of the USA, click HERE to locate Canon in your region and find your support options.

New Contributor
Posts: 2
Registered: ‎08-22-2017

Re: EOS Utility not working with Windows 10

I have read through this message from beginning to end and tried every suggested option, unfortunatly without any effect. After lot's of frustrating hours googling and trying, I now have it working.


How I made it work (in the end):

I had to install "Media Feature Pack for N edition of Windows 10 Version 1703"


Apparantly the version of your windows makes a big difference and the MFP's are hard to find.

To find the exact windows version you are on:

- Click start

- Type "About"

- Select "About your PC"

- Look for Edition (in my case "Windows 10 Pro N") and version (in my case "1703")


Use this to google for "Media Feature Pack" <your edition> <your version> and you'll probably find the correct download for you.

After installation you should also be able to find "Windows media player" in your start menu. I found this the easiest way to check if installation was succesfull. Installing a wrong version of MFP will not give you an error, it'll just not work...




New Contributor
Posts: 4
Registered: ‎08-25-2017

Re: EOS Utility not working with Windows 10

Hi All,


Please could someone help - I've also got the same problem.  I've also been through this thread, watched an unhelpful YouTube video, and scoured Google. 


I've got


- Windows 10 Pro (64bit) - on a Surface Pro 4

- New Canon EOS M5

- Downloaded the latest software from the Canon website (ITU, EOS Utility, DPP)

- Registered for CIG

- I've got a fresh Windows setup with no history, no problems, nothing connected to USB, all settings defaults

- I've tried on my other Windows 10 PC (64bit), same results

- I've not tried installing the Windows Media Feature Pack like one user suggested


All the software correctly installs - yet neither the Image Transfer Utility (ITU) or EOS Utility (EU) works


EU - running the EU utility, it brings up the "Connect an EOS camera" screen, with a button "Pairing over WiFi/LAN".  When clicking, it just shows a blank Camera model / MAC address / IP address.  The camera is "ON", WiFi button pressed.  I've tried EU2 and EU3 - these applications 'load', with all buttons greyed out and no functionality

ITU - when clicking on the executable, nothing happens.  The executable process can be seen via Task Manager into the background.  No images are downloaded


I can successfully connect my camera to my Android Mobile and use the Canon Camera Connect App

I can successfully view images on my TV via DLNA

I can successfully upload images to Irista. 

Yet the EU & ITU software for Image transfer simply doesn't work

I can't find any workaround


May I point out to Canon that there's nothing in the EOS M5 user manual for connecting the camera to a PC.   This is fine if the software is trouble free, although it's not, and there needs to be at least some guidance on how it works.


Any advice or guidance appreciated





August 2017





Esteemed Contributor
Posts: 4,362
Registered: ‎06-25-2014

Re: EOS Utility not working with Windows 10

Are you sure you're looking at the full-length user manual? These days, the printed one that comes with the camera is apt to be abbreviated.

Boston, Massachusetts USA
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement