cancel
Showing results for 
Search instead for 
Did you mean: 

What flash transmitter/receiver?

mthibodeau
Contributor

I have a Vivitar DF-286 DSLR AF flash and I want to use it off camera on my 40D and eventually 5diii - it is supposed to have a "built-in slave function" and it is TTL compatible, though it doesn't have adjustable power settings like a Speedlite. 

I asked B&H what I could use and their recommendation is a $500 set, which isn't really in my budget right now (hence the cheapo flash to begin with), but I think it's all they sold that would work.  I've tried researching on my own but feel a little overwhelmed at the options - I'm looking for something under $100, because I just want to mess around and practice some before upgrading to something better later. 

 

Any recommendations on what I should get?  How do I know what will work with my flash/camera - what attributes/features am I looking for?

 

Thanks!

9 REPLIES 9

pjmacd
Enthusiast
I have successfully used a transmitter/receiver combination from Aputure [sic] on my 60D and 580EX II. These are available from amazon.com for well under $100. They are not the same quality as a Pocket Wizard but cost much less, which I think is your point.

Thank you for that information.  I'm still not clear on what my options are, though - how do I know which kind will work on my Vivitar flash and Canon cameras?  In other words, will ANY transmitter/receiver combo work and it's just a decision of price/brand and features, or do I need something specific (B&H sells more than 2 kinds, but the salesperson only offered those two as options for me, for example).

Thanks for any guidance.

If the Vivitar works in the hot shoe of your camera, then any transmitter/receiver pair that is designed to work with Canon equipment will work for you. Just put the transmitter on the hot shoe of your camera, and put the receiver on the flash. Make sure they are set to the same channel, and you should be good to go.

Thanks - that helps!

Yongnuo is the gold standard in knock-off triggers.  The 622 is available on Amazon for under $80 with Prime and offers full TTL support.  The YN 602 was the knock-off trigger that started it all.  You can get a set on Amazon for like $25.  Note that it only offers manual triggering.

 

I have a set of 622s, and I’ve got five 602s with two transmitters (the 602 use separate transmitter and receiver, while the 602 is a transceiver).   The 622s are nice and all, with eTTL support, but that are pretty big (physically).  The 602s are teeny tiny, and the receivers have 1/4" threads on the bottom for mounting to light stands.  The size also makes it nice to use as a remote shutter trigger with the attached cord.   I mostly use my 602s as I do studio and architectural work, where I prefer manual.  But the 622s are nice for travel just in case I need TTL.

I don't have a camera store very nearby that can help me - that's why I turn to all of you...

 

I tried re-doing everything - taking out batteries, turning on and off, turning on and off in a different order, etc, and the same thing happens. Nothing.

 

I tried the same flash and transceivers on my 40D and it works, no problem - flash fires when I ask it to.  The flash works alone on my 5diii, if I just mount it on the shoe, and the flash works with the transceivers alone (to test fire).  But, combined all together - doesn't work.  

 

Not sure why or what to do - is it my flash at fault or the yongnuos at fault...?

If the combo works on your 40D then it must be the settings on your 5d3.  Did you go through all the flash settings in the menu?  Do you have custom functions set up?  If not you might consider a factory reset.

I have discovered that these transceivers work on my 5D with a Canon flash, so, for whatever reason, the Vivitar flash is the weak link in this setup (even though that setup works on my 40d).

Thanks for all the advice.

That's really odd, makes it sound like an off-camera lighting with Live View situation.  I know you said you weren't using LV.  You may want to try disabling Silent Shooting through the menu anyway.

 

Also, is the VIvitar in manual or TTL mode?  I'd definitely set it to manual just to get it firing.

 

Other than that, I'm out of ideas.  Might be some sort of odd compatibility issue.  I know the PW had issue with the 5d3 in eTTL when it first came out and they had to fix it by firmware.

Announcements