Showing results for 
Show  only  | Search instead for 
Did you mean: 

430ex iii-RT - Multiple flashes won't stay linked/synced


This problem has recently developed.  I use 9 430ex iii-rt's at the same time, one as a master and the others as slaves.  I use 4 on A and 4 on B and 1 for the master.  The master is set to the Manual mode.  All the units, slaves and masters are set to the same frequency and channel.  They use to stay synced for easily an hour or two with no problems.  Lately, after about 5 minutes (sometimes as few as 2 and sometimes as long as ten), the slaves delink and show a red indicator despite the master still showing green.  It does not matter which unit is used as the master.  I've tried several combinations, and the units will no longer stay linked.  I've tried using different frequencies.  Same problem.  It does not matter which camera I use.  Same problem.  Batteries are freshly charged ... same problem.  I shoot all canon cameras that are compatible with the flashes (5DSR and 1DX).  Same problem.  Even if not mounted on any cameras ... same problem.  Any help with this problem is appreciated.  Basically, the units are worthless in a shoot if they keep losing the signal from the master.  Thanks for any help.



After several tests and retries, the issue is clearly that you just need to find a channel and ID that works without interference.  The ID number should use all the same digits, ie. 9999, 8888, 7777 etc.  I used the STS-ET-R3 (version II)  transmitter and eight 430ex RT IIIs.  If the transmitter went to sleep, the flashes delinked, but properly relinked when waking up the transmitter.  At times during the test (which was for an hour), I could see a flash delink and then relink on its own, even when the transmitter was awake.  This is likely due to interference, but again, it properly relinked on its own.  It was not always the same flash that delinked and relinked.  To summarize again, the solution is to find a channel and ID that work for you.  Try and find a couple/three that work, because it is likely it won't always be the same one.  Thank you to everyone who helped contribute to this discussion.

View solution in original post


Product Expert
Product Expert

Hi ajlockwood,

I'm sorry to hear your flashes are losing sync. Since it is happening with every channel you try and with multiple flashes as the transmitters those likely aren't the cause.

One thing to double check is the batteries. I see you mentioned they were freshly recharged. For trouble shooting it would be good to try loading new batteries in the flashes to see if the same thing happens. Overtime as batteries have been charged over and over again they start to lose the ability to power cycle the flashes and to hold the sync. Trying new batteries is the best way to see if that is what is happening.

Another thing to try would be to take the speedlites to a different location and check to see if the same thing happens. Sometimes if there's new interference in the area it could cause issues like this.

If the issue continues at that point we would recommend sending the speedlites in for repair. 

The Canon U.S.A., Inc. online repair portal allows you to set up service in a few simple steps. The repair portal gives you the ability to set up service for multiple pieces of equipment at once, and to receive a repair estimate in the majority of cases, depending on your model and issue. The portal also allows you to upload images or videos that will assist us in repairing your product. You can also select how you wish to be notified of the progress of your repair. The portal's service history section allows you to view all services that have been performed on any of your camera or video products since January 7, 2020. 

Please follow the link below to access our online repair portal to arrange for service:

Instructions for Accessing and Using the Online Repair Portal

You will need to access or create your My Canon Account.

If you already have a My Canon Account and your product is already registered, simply click on the “Get Repair Services” link on the left menu and follow the onscreen instructions to arrange for service for your product.

If you have a My Canon Account and your product is not registered, you must register your product first. Click on the “Get Repair Services” link on the left menu, then click on the “Register Product” link on the right. After your product is registered, click on the “Get Repair Service” link on the left menu and follow the onscreen instructions to arrange for service for your product.

If you do not have a My Canon Account, you will need to create one. After you create your account, click on the “Add Product” link to register your first product. After your product is registered, click on the “Get Repair Service” link on the left menu and follow the onscreen instructions to arrange for service for your product. 

Once you have completed the repair request, you will have an opportunity to print a copy of the request for your records. This request form will also contain shipping instructions and an address label that you will attach to the outside of your shipping box when mailing your equipment for repair.

Thank you Hazel_T.  I have tried everything you already suggested but it still happens.  I also sent all ten units back to Canon for service and they said they worked fine, but it still happens.  


It's a real head-scratcher.  I have no solution -- as yet -- just sharing that it's happened to me as well, though with a 430EX III-RT and a ST-E3-RT.  I ran a test today inside with all my 430's (I have four) connected and they stayed that way for hours -- no issues (they lost link when I had to may obstacles but re-linked when I moved; they woke up after sleeping and re-linked, too).  The times I've lost connection were outside, so maybe there is just increased radio interference.  What I did before testing was reset all the units by clearing the custom/personal function settings.  I use my flashes daily, so I'm just waiting for a drop again.  I also rotate my units, so if I lose link, I'll know which unit I'm using and I have a few ideas I want to try (like trying to get another unit that's currently off to link). 

I understand that the units can lose link: what I don't understand is why they don't re-link automatically every time and have to be power cycled!

I'm in testing mode: if I find anything we can do, I'll we share.

Thank you for sharing that.  You're right about being a real head scratcher.  Will keep working on it.  

I set up a test using my four 430EX III-RT speedlites and ST-E3-RT (Ver 1) where I place each flash in a different room in my house. Timing for 30 minutes segments, I would see if any links were lost then rotate the flashes (to make sure I didn't have a defective unit). Using channels AUTO, 6 and even 10 resulted in one or two failures every time despite using the RT scan feature, which showed those (numbered) channels as strong.

After looking for other examples of losing link with other 2.4 GHZ radio systems (Godox, etc.), it seems the issue came down to either sporadic voltages with rechargeable batteries, RF interference in the ever crowded 2.4 GHZ band, or both. One suggestion was to install "WiFi Analyzer" (for Android phones) to see traffic. I did so and sure enough, the channels I'd been using had a good deal of traffic on them. Channels above 13 were clear. So I switched to channel 15 (despite the RT scan showing channel 15 as weak) and suffered just ONE failure in two hours of testing!

In conclusion, I'm feeling pretty confident I'm losing link due to RF interference (which is due to Part 15 of the FCC Rules – “(2) this device must accept any interference received, including interference that may cause undesired operation.”). I not sure about the rechargeable battery voltages -- it may contribute. I plan on swapping in alkaline batteries and repeating the test.

Of course, my BIG issue it why isn't the unit re-linking after it's lost? If I purposely lose link -- with distance or obstacles -- and resolve the issue, the speedlite re-links. But for some reason, with interference (or rechargeable battery issues), once the link is lost, it's lost for good. Some claim you have to power cycle everything to get the link back. But I found just toggling radio off then on again with the affected unit results in a re-link.

That's helpful.  I do have to power cycle the units to relink them.  It seems one unit infects the others, and all 8 slaves lose link, even when the master is indicating green.  I'll see if toggling radio on and off is quicker.

Today I did a test with four of my ten units.  The master was set to manual mode and wireless, slaves set to wireless.  All used a specific channel.  In less than 10 minutes one of the slaves delinked.  I powered that slave off.  A powered down and restarted the master.  It continued no problem for 30 minutes.  I turned the master off, and repowered the slave I had turned off and switched it to the master.  Once again, everything stayed linked for 30 minutes, no problems.  I turned on the other master, and switched the prior slave back to being a slave.  That broke all the links and the only fix was to power down all units.  I went back to the original configuration (3 slaves and the master - using the same original master).  Again, within 10 minutes the one slave delinked and I powered it down.  The other slaves continued on with no problems.  My next test will be using the one unit as a master against two different slaves, and if that's fine, to add the other two slaves for a total of 4 slaves.  It could be I have one unit that is disrupting all the others.  Used my rechargeable batteries.  I don't think the problem is the batteries.

Thank you for this.  I was shooting all day yesterday with only 2 430s and the ST-E3-RT transmitter, and the links were dropping all day.  Everything had fresh batteries so I knew it wasn't that.  It was driving me nuts!  Having to constantly cycle everything to get them to reconnect took so much time and was so distracting.  I must have done it about 100 times.

Considering that we were in a loft apartment complex where there were tons of wifi signals I would guess that your suspicions are correct.  Hopefully bumping my channels up will help if I run into this issue again.  

Thanks again for the info!

click here to view the press release