Showing results for 
Show  only  | Search instead for 
Did you mean: 

imageCLASS MF644Cdw Airprint name keeps changing


I have a MF644C and about every week or so the Airprint name changes. This prevents me from printing via my Macbook Pro until I delete and re-add the printer. Under "Settings/Registration: Preferences: Network Settings > AirPrint Settings" I originally set the Printer Name to "Canon MF644C", then it suddenly changed to "Canon MF644C (dd:ed:b5)" and most recently changed to "Canon MF644C (dd:ed:b5) (dd:ed:b5) (7)". I really don't care what the name is, but why does it keep changing?



This affects me as well.

I have even tried to disable IPv4 mDNS completely and only keep IPv6 mDNS active. (I use both IPv4 and IPv6 on my LAN.)

Didn't help.


Also there is a fixed IP set on the router for this printer, so the IP has not really changed in the past two weeks. Still the printer tells me that "the IP address of this printer has changed" after some boots.


This is really an issue as I always have to return to the printer's web admin page to revert to the correct mDNS name, otherwise printing from my Mac doesn't work at all (unless I'd remove and re-add the printer, which is a PITA).


Canon, it is unclear how this could have passed the quality assurance process. I have even updated printer's firmware, still didn't help. Plese fix this ASAP.

I appreciate his numerous posts and consider it absurd that anyone would try to cast it as spamming. Each post was a substantive post that stands on its own, often in response to others separate posts.


It is nearly a year and a half since this was first posted, and Canon still has not fixed this well documented problem. Sad.

I had to buy another Color Laser printer today and I bought a HP…


I have the exact same issue on mac. I tried using Mac drivers from Canon but they don't work either. changing the airprint name on the printer sounds like a better workaround for now. Maybe I will write a mac script to do this everytime a reboot my mac.

Hi Guys, I also have this problem... I played around with the wireless setting and it just doesn't go away. However, I switched it to wired cable to my router and the problem goes away. Maybe you should all try and see this works around works, it will definitely save some headaches though, although its a workaround. Cheers.


Just to add a bit more data, while investigating this issue with my family's ImageClass MF642C I found that I could reliably reproduce the issue by: a) switching the device's network connection from wireless to wired then back to wireless in the touch-screen options (Preferences > Network > Select Wired/Wireless LAN); or b) by rebooting the router while the printer was on and connected to the wireless network. Rebooting the printer or turning it off completely (including unplugging it) did not cause the airprint name to change. When the airprint name did change, from these methods, I was still able to access it via my ios device to print, so I'm not sure how it can eventually become unavailable entirely. As a work-around for my macs, I set a static IP address and used the ip address and airprint protocol to connect to the printer. That way, it's not dependent on the variable airprint name. As for idevices, which depend on the multicast airprint name, you just need to select the printer by it's new name.

The issue still happens to me once every six months or so. Therefore I wrote a simple daily python job that checks if the name changed and amends it if necessary. Problem solved.

If you don't mind sharing your code, I'd really appreciate it!


Agree, just escalate to the developers already!!!!

This is insane. I have multiple printers and other devices using mDNS in my network, and no other service disappears or change their names.

Funny thing is also, this seems to be a bigger issue with the pricier laser printers, my canon mx925 works much better in regards to its bonjour implementation and at least does not disappear as often.

The mf742cdw keeps disappearing from the network after going to sleep almost immediately or within 5min and changing its name after a few hours it seems!

I can see that it drops the published Services:


first, while keeping:



I will keep watching these two to see if they disappear later, or are maybe the reason the silly code upon trying to reregister switches to a new name.

But If the Canon Laser guys would go to the consumer ink printer guys and ask for their bonjour implementation we would already be in a better, yet far from perfect state...

Or maybe just get real devs to rework that implementation!!!!!!!!

For the disappearing part, I have tried mDNS reflectors and caches which only help so much. But the name changing thing is still the worst.  

My Epson Printer is always available, never disappears, and for the last 3 years has yet to change its name. (YES CANON ON THE SAME DARN NETWORK, BEHIND THE SAME ROUTER....!!!)

Why do over 300 Services stay visible and keep their names without a problem on my network, but Canon just won't get their implementation right?

avahi-browse -at | wc -l

C'mon canon, mdns is not that hard to understand!


03/14/2023: New firmware version 1.8.1 is available for EOS R6

03/02/2023: New Firmware Updates Are Available:

EOS R7 - Version 1.3.0EOS R10 - Version 1.3.0
02/24/2023: We've updated Share Your Photos

2/07/2023: New product announcements!

EOS R8 EOS R50RF-S55-210mm F5-7.1 IS STMRF24-50mm F4.5-6.3 IS STMRF15-30mm F4.5-6.3 IS STM
01/18/2023: New firmware version 1.1.1 is available for EOS R6 Mark II
01/09/2023: Help ensure your autofocus is properly aligned with a Canon Precision Alignment
01/03/2023: Welcome to CES 2023!
12/08/2022: New firmware version is available for EOS C70
12/07/2022: New firmware version 1.7.0 is available for EOS R5
11/22/2022: New firmware available for EOS R3, EOS R7 and EOS R10
11/16/2022: We're thrilled to be ranked among the Best Employers for Veterans in 2022 by Forbes.
08/31/2022: New firmware version 1.1.1 is available for RF 70-200mm L IS USM
08/09/2022: New firmware version 1.2.0 is available for CR-N 300
08/09/2022: New firmware version 1.2.0 is available for CR-N 500
07/14/2022: New firmware version 1.0.1 is available for CR-X300
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version is available for EOS-C500 Mark II
05/26/2022: New firmware version is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version is available for EOS R5 C
03/23/2022: New firmware version is available for EOS-C70
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.