Showing results for 
Search instead for 
Did you mean: 

Pixma MX922 will not connect to wifi 6 router

New Contributor

I have a Pixma PX922 printer that I have never had any problems with.  I recently replaced my wifi router with a TP-Link Archer AX1800 which is wifi 6 (802.11ax) in order to take advantage of WPA3 security.  All of my wifi capable devices have no issues connecting to the router, however, when I attempt to connect my printer to the wifi network it fails.  The network discovery lists the SSID in the list of available networks, howeve, when I attempt to connect to the network I get the message "Failed to connect to the access point" followed by a list of reasons all of witch I have checked and double checked.  The failure occurs whether I use the WPS method or the Standard Method.  I haven't had any issues with wifi connectivity until I installed this router.  I checked the firmware for this printer and it is the latest Canon offers.  I have had to rely on wired connectivity to access this printer.  Anyone else have an issue with this combination?  Is this printer's wifi hardware not compatible with 802.11ax?  Thanks for any info anyone can provide.


Esteemed Contributor


Its unlikely the MX922 will ever support WPA3.


If its chipset was capable, it would require a firmwre update to support this encryption standard.  Due to its age, I would not count on this support.


You best bet would be to enable both WPA2 and 3 on your router (if capable) to support backwards compatibility with devices that support older encryption standards. 

Bay Area - CA
~6D2(v1.1.0) ~Many Lenses ~DxO PhotoLab Elite ~Windows10 Pro ~EVGA RTX 2080 FTW3 Ultra ~ImageClass MF644Cdw ~Pixel6

Hi Rick,

Thanks for the reply.  I have set up my router for WPA2/WPA3 Mixed.  All my other devices connect and as many of them are several years old I am sure they do not support WPA3 encription.  My concern is that for some reason the MX922 hardware/firmware for wireless is not compatible with 802.11ax.  My previous router was 802.11ac which the printer had no trouble connecting with.  I have not tried to configure my new router as WPA2 only which I could try to determine if it is the encription that is causing the issue.  As I mentioned in my post my fallback is to use the tried and true wired connection and not sweat it.