cancel
Showing results for 
Search instead for 
Did you mean: 

MX922 goes to sleep and loses WiFi connection

bruceadler
Occasional Contributor

I have a new MX922 that replaced a dead MX870. The old MX870 worked fine until it died but this new MX922 doesn't work correctly on my WiFi network. And the only thing that's changed is the printer (all the other PCs and printers and the Wifi router are the same as before and still work just fine). The new MX922 goes to sleep and can't be woken up from any PC on my network (to print or scan). The old MX870 NEVER had a problem on this WiFI network and NEVER had a problem with sleep mode. I also still have two MX890s that still work just fine. When the MX922 stops responding to pings, the blue WiFi logo on the front is on, and the Network Configuration Page always says "Connection Active" (but it's not).  Any suggestions that it's my router or my PC driver's fault is nonsense. It's clearly a MX922 WiFi bug which Canon needs to fix ASAP.

 

Over the past few weeks I've discovered that if the printer goes to sleep for an extended period it frequently "loses" it's WiFi connection and nothing I do from my PC will let me print to or scan from it. Basically it stops responding to pings (which tells me that its WiFi network connection is the issue). I usually discover the printer is offline line first thing Monday AM (after the office has been closed all weekend).

 

When the MX922 goes into a coma the only way I've found to wake it up is to either power-cycle it, or do go into the Device Settings menu and print out the current Network Configuration Page (it sometimes starts printing/scanning again when I exit out of the menus). AND sometimes after waking it up via the menu trick it operates very very slowly (like the Wifi connection is poor or congested) and I end up having to power cycle it to fix it. I shouldn't ever have to power cycle the printer just to wake it up (especially since it probably uses up some ink to recharge the print head each time it powers on).

 

Since I got it about 6 weeks ago, this printer has gone into a coma about once a week. Recently I tried disabling the Wireless DRX option and that seems to have made it worse. Since I disabled that option, It's gone into a coma 3 times in the past two days.

 

 

 

1 ACCEPTED SOLUTION

dgkerr53
New Contributor

First thing I did when I bought this printer is assigned a static IP to it.  I always have to turn the printer off and then on again after I send a job to it if it's been idle more that a couple of days.  I'm looking forward to dumping this sorry printer in the near future.  

View solution in original post

106 REPLIES 106

bruceadler
Occasional Contributor

spirestocks, I read your lenghty posts in the other thread. Two points:

 

1. your troubles initially configuring your MX922 (requiring you to config as usb printer, then wired printer, then wifi printer) don't seem directly relevant to the issue of the MX922 going to sleep and losing its wifi session. I've succesfully switched my MX922 between wired and wireless multiple times without doing a USB config, but I can accept that there are ways to so badly screw up Windows 10 and the MX922 that a USB config might me needed. I think those issues aren't related to the wifi/sleep issues. Also, your issues seem to be specific to WSD in Windows 8 or 10. People are reporting wifi/sleep issues on other Windows releases and other OSes. Regardless, people with the wifi/sleep issue have a *correctly* configured network connection to the MX922, and are able to use their MX922 continuously (for days at a time), up and until it goes to sleep for more than a few hours (or perhaps over the weekend in some cases).  

 

2. part of your lengthy posting in the other thread seems to say that you think assigning a static IP address and reserving it on the router solves the wifi/sleep problem. I know for certain that assigning a static IP doesn't fix the problem on my network. If my MX922 (with a static IP address) goes to sleep long enough it stops responding to the network and has to be power cycled to force it to re-establish its wifi connection. About the only thing assigning a static IP address will do is prevent wifi devices that join your wifi network from getting your MX922's dynamic IP address while the MX922 is asleep. But that can only happen if they join the wifi network after the MX922 has been asleep for longer than the DHCP server's reservation timeout. Setting your DHCP timeout to something like 7 days (assuming you use your printer at least once a week) should prevent this without having to assign a static IP address.

 

Regardless, if the MX922 is still connected to the wifi network, assigning its previously assigned dynamic IP address to a second device, or assigning the MX922 a different dynamic IP address, should NEVER happen.

 

A correctly designed wifi device should *NOT* require a static IP address. It should "keep alive" it's session with the wifi router and refresh it's IP reservation with the DHCP server as needed. The fact that the MX922 doesn't correctly manage its dynamic IP address with the DHCP server is just another symptom of it not keeping its wifi session active after it sleeps for an extended period. Wifi devices are supposed to know what the wifi session timeout period is and periodically wake up and keep the wifi session active by responding to status packets from the wifi router. Similarly they're also expected to as needed refresh their dynamic IP address reservation with the DHCP server (so that the DHCP server doesn't ever assign the MX922 a different IP address, or assign the MX922's IP address to another device). 

 

In other words, if the MX922 managed its wifi session correctly there would never be an problem with dynamic IP addresses because the MX922 would always be able to respond to the DHCP server's queries.

spirestocks
Frequent Contributor

bruceadler, Thanks so much for taking the time to respond.  Subsequent to my original post, during more troubleshooting, yes, the MX922 seems to not manage the connections very well; the question now is how to recover especially in the wireless mode, which seems to be the most difficult to resolve.  I am working on a step by step method to resolve, but in a nutshell, I put the printer via the touchscreen in the mode I want to resolve and reset the LAN settings. 

MENU>Setup>Device Settings>LAN settings>Reset LAN Settings

The advantage of knowing the reserve address/static ip address that the router is assigning to the printer MAC address allows someone, after the reset LAN settings, to go in manually and add the expected assigned ip address via the printer touchscreen, to include the subnet and then gateway (router) information via the following path:

MENU>Setup>Device Settings>LAN settings>Other settings>TCP/IP>IPv4>Select Yes>IP Address>Manual Setup

Once I know the printer has the expected, static/reserve address, I shut off the printer, and then shut off the router as well.  Then I turn on router and then printer and initiate a wireless connection via:

MENU>Setup>Device Settings>LAN settings>Wireless LAN setup. Sometimes it takes a couple recycles of power between the router and the printer, but by typing in the reserve ip address that is tied to the router, the printer has re-initiated connection with router everytime now.  Hence, as long as the latest Canon ports/drivers are installed for each method (USB,Wired, Wireless) people shouldn't have to worry about setup re-initialization because this sequence has now worked to resolve the issue. After the issue is resolved, I go the the address of the printer via the address bar, lets say, 192.168.1.250 and disable the ipv6 option, and the settings for the LAN DRX mode.  I also add a location for the printer.

MENU>Setup>Device Settings>LAN settings>Other settings>Wireless LAN DRX setting

MENU>Setup>Device Settings>LAN settings>Other settings>Wired LAN DRX setting

By resetting the LAN settings then manually adding expected TP/ICP settings reserved in router with MAC Address and then re-establishing a connection after power resets for both router and printer seems to resolve the issue.  Lets keep each other posted.  Thanks

 

 

bruceadler
Occasional Contributor

spirestocks,

 

you must be having a completely different network issue with your MX922 because the wifi/sleep problem on my MX922 has ALWAYS been fixed by simply power-cycling the MX922 (ie power it off, wait 30 seconds, then power it on)

spirestocks
Frequent Contributor

The underlying ongoing 4+ year MX 922 issue is the same.  After the sleep mode goes into effect, the cycling of power works if the DHCP address that was given to printer remains the same.  However, if the dynamically assigned address [in the interim] is given to another device, then the IP address shown on printer is no longer in sync with the previously, now, reassigned IP address that was originally given to printer and now is assigned to another device.  This is most apt to happen if current printer IP address is near the bottom (smaller ip address, such as 1.2/1.3) of the DHCP range.  When this happens, in my experience, there is no way to tell which new DHCP IP address the router is trying to re-assign to the printer because the printer is not recognized and does not show up on the router attached devices; because, the IP address showing on printer touch screen is now taken by another device.  That is where the complexity and diffculty arises, because recycling the printer power and/or the router doesn't solve the problem.  What I found is if you reset the LAN settings on the printer which clears the IP address in printer and disables the printer LAN connection, you then can select the Wireless mode on printer which assigns the SSID in printer to BJNPSETUP for wireless printer mode only.  At this point, you query the router with the Wired IP address Setup on printer.  However, this doesn't always resolve either, which is why I suggested having router address/assign or setup IP static address in router  associated with each (both modes/methods wired and wireless with separate IPs) of the printer MAC Addresses (unique for each mode: wired and wireless and ports will show by MAC Address the number that matches the method).  I select the last DHCP address in router range (192.168.1.254 current range on my NETGEAR) to wired mode and the second to last DHCP router range IP address to wireless mode/MAC address, then I know which IP address the router will try to assign to printer after sleep mode based on mode selected on print touch screen.  If the Wireless Setup doesn't work, I go into the printer TCP/IP settings and manually set the IP address on the printer that matches the router IP address for static/assigning address, that way, I know that the IP address on the printer will match the address that the router will select for printer modes that each have a different MAC Address for both wired and wireless method.  If I then recycle power to both the router and the printer, this usually will work without having to re-initiate the setup using the downloaded drivers.  If it doesn't re-initate, as mentioned before, I can re-install the drivers and during that process, I know that the IP address I had already manually set in the printer will now match the static IP address in router that I associated with MAC Address and this address will now show up in the next address option during the setup process with drivers (USB, wired, wireless mode).  This works everytime as long as the next button is selected after I choose next address.  What is confusing is that the top paragraph during driver setup process says that the printer was not detected even though the next address I see during drivers setup process matches what is on the printer and in the router and in the detected devices on router.  This will work after clicking on next button, but I still have to re-cycle power for printer and router and each time I do this another set of Canon printer driver ports is established/added.  To avoid having so many Canon drivers installed, I change the port name to match the IP address assigned in router.  I have to go through this process twice for both the wired and wireless modes after choosing each mode and making sure the mode on the printer is selected and the proper mode is prepared (wired: connected cable to router LAN).  If you do the wired method first in setup you have to make sure IP Address in printer is changed to reflect IP Address for Wireless when you go through that setup process.  If I have to go through installing the drivers, I make sure I delete all of the printer icons in the computer printer/device control panel associated with MX 922 printer ONLY and I delete the Canon ports also, noting, when I do see the new printer icon after driver setup process, I have to go in and change the port from WSD to the correct Canon port for desired mode (wired or wireless), which was just added during the driver setup process. If the printer DHCP IP address is ever reassigned, I hope this helps people to get the printer and router synchronized.

dgkerr53
New Contributor

So, apparently, there is no answer to this issue.  Out of the box, this printer loses WiFi and won't print unless I reboot.  That's pretty poor.  I will give this printer and this forum a couple of weeks, then I will trash this printer and never buy another Canon anything.

pscanon
Occasional Contributor

You can't read?  I posted the fix.

 

 My mx922 now works fine with cloudprint, has been up since yesterday.

 

 

bruceadler
Occasional Contributor

@pscanon wrote:

You can't read?  I posted the fix.

 

 My mx922 now works fine with cloudprint, has been up since yesterday.

 

 


Disabling DRX doesn't work in all cases.  If you go back and read my original post, I reported that on my MX922 disabling DRX in fact made my printer behave worse. 

 

Either you got lucky and got a MX922 which doesn't have the exact same sleep-failure bug as everyone else, or you just haven't let your MX922 go idle for long enough to trigger the bug. 

 

And even on my MX922 sometimes it works fine even after a long sleep (eg from Fri PM to Mon AM) and other times it fails after being idle for only 4-6 hours. Perhaps it's triggered by temperature, or static-discharge, or very large print jobs, or whatever. Whatever triggers it it makes it seem completely random whether MX922 works just fine or goes to sleep and never wakes up.

 

 

I suspect the failing MX922s all share some sort of bug that affects how the MX922 keeps track of realtime events. And that timing bug causes the MX922 to sometimes miss the window for (just or stops doing), the periodic handshakes with the Wifi router to keep its session alive. My wild-assed-guess is that some timing related component is sometimes out of spec just enough so that only some of the MX922's are affected. For example, if the MX922's Wifi clock were only accurate to +- 20% rather than +-1%, then some MX922s would work fine and others would be broken. So perhaps in your case, changing your DRX setting tweaked your MX922's timing just enough in the right direction to compensate for whatever the underlying bug is that makes the MX922 so unreliable for so many people. And in my case it tweaked my MX922's timiing further outside the correct operating range. But like I said that's a 100% pure guess. Perhaps someday when I completely run out of other things to do I'll snoop the Wifi traffic and get some hard evidence.

pscanon
Occasional Contributor

 

My mx922 printer is about 3 years old.  There is nothing special about it.  I updated the firmware in November, hoping that would fix the sleeping problem. (it didn't).   I assigned a static IP internal address, 10.0.0.9, 3 years ago in the router and and the printer manually, and never changed it. 

 

I had the same exact issue with it going to sleep and losing cloud print until I disable both the wired and wireless DRX settings, through the printers web interface from my Chromebook.,  a few days ago on a hunch. I restarted it remotely to apply the settings.

 

SInce disabling DRX,  the only time I've had to restart it is after losing power.    When I did, I used the menu to tell it look for cloud print jobs, there were none at that time.

 

It's been more than 30 hours since I last restarted the printer and my house closcks. . I printed one page yesterday  and another today anout 20 minutes ago.

 

The display was off most of yesterday and still off this morning. The wifi and blue menu LEDs have been on  continuously..  It woke up turned on when I printed the recent page. 

Screenshot 2017-05-06 at 10.37.39 PM.png

 

Screenshot 2017-05-06 at 10.39.26 PM.pngScreenshot 2017-05-06 at 10.38.27 PM.png

It may be unrelated but the wifi transmission speed has risen from 65Mbps tp 72.2Mbps after the last configuration change.

spirestocks
Frequent Contributor

There is an answer. Set the IP address in router to static for both modes of the printer; wired and wireless based on different MAC addresses and it solves the problem as long as the IP address you set is above (still within DHCP range) the number of devices that will use your DHCP range, so there wont be a conflict when the printer goes to sleep and then is restarted.  If for some other reason, the printer and router still do not synchronize, you can always reset the printer manually as listed in my previous thread(s) and then reconfigure using the router static IP address you assigned for both modes.  This has always fixed the problem.  Saying it shouldn't be this way may be valid and noting for liability reasons Canon will not suggest to reconfigure your router for static ip for obvious reasons, but the solution I listed just prior to this message worked every single time and since the IP static address, I have never had a problem.