cancel
Showing results for 
Search instead for 
Did you mean: 

MX922 goes to sleep and loses WiFi connection

bruceadler
Occasional Contributor

I have a new MX922 that replaced a dead MX870. The old MX870 worked fine until it died but this new MX922 doesn't work correctly on my WiFi network. And the only thing that's changed is the printer (all the other PCs and printers and the Wifi router are the same as before and still work just fine). The new MX922 goes to sleep and can't be woken up from any PC on my network (to print or scan). The old MX870 NEVER had a problem on this WiFI network and NEVER had a problem with sleep mode. I also still have two MX890s that still work just fine. When the MX922 stops responding to pings, the blue WiFi logo on the front is on, and the Network Configuration Page always says "Connection Active" (but it's not).  Any suggestions that it's my router or my PC driver's fault is nonsense. It's clearly a MX922 WiFi bug which Canon needs to fix ASAP.

 

Over the past few weeks I've discovered that if the printer goes to sleep for an extended period it frequently "loses" it's WiFi connection and nothing I do from my PC will let me print to or scan from it. Basically it stops responding to pings (which tells me that its WiFi network connection is the issue). I usually discover the printer is offline line first thing Monday AM (after the office has been closed all weekend).

 

When the MX922 goes into a coma the only way I've found to wake it up is to either power-cycle it, or do go into the Device Settings menu and print out the current Network Configuration Page (it sometimes starts printing/scanning again when I exit out of the menus). AND sometimes after waking it up via the menu trick it operates very very slowly (like the Wifi connection is poor or congested) and I end up having to power cycle it to fix it. I shouldn't ever have to power cycle the printer just to wake it up (especially since it probably uses up some ink to recharge the print head each time it powers on).

 

Since I got it about 6 weeks ago, this printer has gone into a coma about once a week. Recently I tried disabling the Wireless DRX option and that seems to have made it worse. Since I disabled that option, It's gone into a coma 3 times in the past two days.

 

 

 

1 ACCEPTED SOLUTION

dgkerr53
New Contributor

First thing I did when I bought this printer is assigned a static IP to it.  I always have to turn the printer off and then on again after I send a job to it if it's been idle more that a couple of days.  I'm looking forward to dumping this sorry printer in the near future.  

View solution in original post

106 REPLIES 106

spirestocks
Frequent Contributor
Clarification. If you sign the static ip address outside the DHCP range, you wouldnt have to reset the printer. As stated previously, once I assigned static ip address outside of DHCP range, I have never had an issue and it has been years

bruceadler
Occasional Contributor

@spirestocks wrote:
Clarification. If you sign the static ip address outside the DHCP range, you wouldnt have to reset the printer. As stated previously, once I assigned static ip address outside of DHCP range, I have never had an issue and it has been years

1. many routers do NOT allow assigning static IP addresses outside of their assigned DHCP range. 

 

2. this workaround does not always work. I and others have repeatedly responded that we still have MX922 wifi problems even though we've configured the printer with a static IP address.

 

3. not all MX922 printers seem to be affected by the wifi-falls-down-and-can't-get-up problem. You apparently got lucky and got a MX922 that doesn't really have the same wifi problem. Rather it appears to me that you've got a buggy DHCP server that doesn't know how to manage its pool correctly and/or have a DHCP server that doesn't pay attention to the ARP messages from other systems which should clue it into that a IP address it thinks is available is still in use. Some older (unpatched) Windows-based DHCP servers and some older DSL/Cable-routers have this problem.

spirestocks
Frequent Contributor
Is your ip address outside the DHCP range

spirestocks
Frequent Contributor
I have had the vo to sleep problem many times and tried many fixes and my router is fine. Since assigning static IP address outside of DHCP, I have never had a problem in years. If for some reason one can not assign outside DHCP, then just have to recycle when that original ip address is taken during sleep mode

brianprice6
Occasional Contributor

I too have had this problem since I bought this printer 8 months ago.  I've set a correct static IP address, and set the Wireless LAN DRX to disabled long ago.  I still have this problem very frequently.  Sometimes it works, sometimes not after some time has passed and the printer and/or the Mac have gone to sleep.  I've had two different MAC OSs with this same problem.  The Mac is completely up to date, my router is fairly new and has the 2.4 GHz band.  I have never had this problem with another device, printer or otherwise in 20 years of using systems.  I'm an IT guy so I hopefully know what I'm doing here.  I've worked with Canon Tech Support btw, and although we tried a number of things (mostly related to static IP) it's still unreliable.  It always work when I'm talking to them of course (is that a law of the universe?)

 

At times it will reconnect.  Sometimes after wake up the first print job fails with the 300 Printer Won't Connect error.  Sometimes if I wait a bit, submit another print job, and then delete the first print job it will think about it for a while, then print.  Sometimes restarting my Mac and/or the printer helps, but not always.  

 

This is bad.  Clearly the printer is unreliable - it's not the router, or the Mac given that everything else I own connects reliably.  And - if this is a home network - there is no good reason for having to set a static IP address.  I've never had to do that before in my home configuration of a printer.  Might make sense in an office to do that, but not at home.  And regardless - it hasn't consistently solved the problem. 

 

I've come to the conclusion that this printer should be recyled as unusable and a new non Canon printer purchased.  It's a cheap printer and my time is more importnat to me than a hundred bucks or whatever.  It's too bad that Canon won't step up, admit that there is a problem, and put a firmware fix on this.  


@brianprice6 wrote:

It's too bad that Canon won't step up, admit that there is a problem, and put a firmware fix on this.  


They did respond to the problem by discontinuing the model and its support.  I'm heading to Epson.

brianprice6
Occasional Contributor
Me too - or HP. The local Office Depot, unfortunately, does not carry any of the top rated consumer grade printers.

It must be a problem that is not fixable with firmware.

brianprice6
Occasional Contributor

I decided that I didn't want to buy another printer right now, so I moved it close to the router and connected it with Ethernet cable. Working fine of course.....

Did you set your static IP address above the dynamic addresses, so that your printer address would never be assigned to another device if you turn your printer off or it goes to sleep.  When I set my static ip address above the dynamic addresses, in fact, I set it to the second to last address in the range, I have NEVER had a problem since, for years now.  I hope this helps

brianprice6
Occasional Contributor

Thanks spirestocks.  I went through a bit of work to get it wired, and I'm tired of working on this - so many hours over many months.  I may try your suggestion after I've had some quality time without thinking or working on this. That aside, I believe my router is assigning the addresses, and I set my static well above what I believe the dynamic range should be given my number of devices.  If the router is not releasing the IPs when a device disconnects for a long period of time, then I could see how this could come into play.  My guess is that's OK - but could be wrong,  Thanks for your suggestion.