cancel
Showing results for 
Search instead for 
Did you mean: 

MX922 goes to sleep and loses WiFi connection

bruceadler
Occasional Contributor

I have a new MX922 that replaced a dead MX870. The old MX870 worked fine until it died but this new MX922 doesn't work correctly on my WiFi network. And the only thing that's changed is the printer (all the other PCs and printers and the Wifi router are the same as before and still work just fine). The new MX922 goes to sleep and can't be woken up from any PC on my network (to print or scan). The old MX870 NEVER had a problem on this WiFI network and NEVER had a problem with sleep mode. I also still have two MX890s that still work just fine. When the MX922 stops responding to pings, the blue WiFi logo on the front is on, and the Network Configuration Page always says "Connection Active" (but it's not).  Any suggestions that it's my router or my PC driver's fault is nonsense. It's clearly a MX922 WiFi bug which Canon needs to fix ASAP.

 

Over the past few weeks I've discovered that if the printer goes to sleep for an extended period it frequently "loses" it's WiFi connection and nothing I do from my PC will let me print to or scan from it. Basically it stops responding to pings (which tells me that its WiFi network connection is the issue). I usually discover the printer is offline line first thing Monday AM (after the office has been closed all weekend).

 

When the MX922 goes into a coma the only way I've found to wake it up is to either power-cycle it, or do go into the Device Settings menu and print out the current Network Configuration Page (it sometimes starts printing/scanning again when I exit out of the menus). AND sometimes after waking it up via the menu trick it operates very very slowly (like the Wifi connection is poor or congested) and I end up having to power cycle it to fix it. I shouldn't ever have to power cycle the printer just to wake it up (especially since it probably uses up some ink to recharge the print head each time it powers on).

 

Since I got it about 6 weeks ago, this printer has gone into a coma about once a week. Recently I tried disabling the Wireless DRX option and that seems to have made it worse. Since I disabled that option, It's gone into a coma 3 times in the past two days.

 

 

 

1 ACCEPTED SOLUTION

dgkerr53
New Contributor

First thing I did when I bought this printer is assigned a static IP to it.  I always have to turn the printer off and then on again after I send a job to it if it's been idle more that a couple of days.  I'm looking forward to dumping this sorry printer in the near future.  

View solution in original post

106 REPLIES 106

 

 

Message #43 in this thread fixes this problem!

bruceadler
Occasional Contributor

@psarahtonen wrote:

 

 

Message #43 in this thread fixes this problem!


No it doesn't.

 

Message #43 says to power off and then power on the printer. That's not what I call a viable fix. Power cycling the printer does get the printer back online for a few days. But it's a temporary work around and is an implicit confirmation that there's no permanent fix. 

 

Message #43 also quotes message #35 which suggests disabling the DRX option. Is that the "fix" you're refering to? But as reported by myself and others, disabling the DRX option also does NOT work permanently. I suspect that disabling DRX only seems to work because when you change that option the printer resets its  wifi connection. And it's resetting the printer's wifi connection (not changing the DRX option) that seems to make Wifi temporarily work again. The only permanent fix is to not use the MX922 via Wifi (which is what I ended up having to do). In other words, I've tried all the suggested "fixes" and it's still my opinion that Wifi on my MX922 is defective and there's no permanent fix. And that all the suggested fixes which cause the prnter to reset its wifi connection are only temporary "fixes" and have no real long-term effect on how frequently the MX922 loses its wifi connection.

spirestocks
Frequent Contributor
Since my post of message #53 and your reply on #54, I have never had the problem again. Without getting into whether this shouldn't be necessary or the design of the printer, the fact is that assigning a static ip address outside the DHCP range absolutely solves the problem and allows anyone/device to print in wireless mode. One can contend all they want that this is a bad design and shouldnt be necessary but once again it does solve the problem. Try it and you can confirm a year from now. Peace


@spirestocks wrote:
Since my post of message #53 and your reply on #54, I have never had the problem again. Without getting into whether this shouldn't be necessary or the design of the printer, the fact is that assigning a static ip address outside the DHCP range absolutely solves the problem and allows anyone/device to print in wireless mode. One can contend all they want that this is a bad design and shouldnt be necessary but once again it does solve the problem. Try it and you can confirm a year from now. Peace

Just here to give creedence to spirestocks recommended fix of assigning a static IP to your device.  If you look at all my posts here (wireless printers forum), you will see that I too also recommend this proceedure to fix this behavior.  This is regardless of design or what you should or shouldn't have to do.

 

Dynamically assigned IPs have a lease time.  This is a preset amount of time that a router "loans" an IP to a device connected to your network.  When that devices goes to sleep, is turned off or leaves and the router doesn't "hear back" from it during the lease time, the router will reclaim the IP and put it back in the pool of available IP addresses the router hands out to new devices.

 

Devices come and go, they sleep, wake and sometimes get turned off for extended periods of time.  A router is just doing it's job.  All power cycling does (covered earlier) is force the device to connect and receive a new IP address.  The router will hand out the next available address in its pool.  If its the same one the device had before, you can print, but if another device has connected and been given the IP address you printer or computer thought it had... printing will fail.

 

Assigning a static IP, (also called) Address Reservation (assigning static IP by MAC address) is a way to ensure a device ALWAYS gets the same IP address, regardless of the amount of time it was last used, turned on of "seen" on the network.  Its a simple way to ensure every device on your network will ALWAYS know how to communicate with your printer (or other device) because it it will always get the (same) static assigned IP. 

 

Take heed.  This is a "set and forget" recommendation.  It takes 5 minutes.  You do it once and you won't have to deal with this issue or wonder why you can't print again.     

 

If this is not clear, see my other post here.

 

 

~Rick
Bay Area - CA
~6D2(v1.1.0) ~Many Lenses ~DxO PhotoLab Elite ~Windows10 Pro ~EVGA RTX 2080 FTW3 Ultra ~ImageClass MF644Cdw

bruceadler
Occasional Contributor

If assigning a static IP address problem fixes your wifi-connected MX922 then you got lucky and don't have the same problem as other people have with their wifi-connected MX922s. My printer has had a static IP address since its very first day and it still randomly loses its wifi connection after going to sleep. In other words, if you've got a MX922 which goes to sleep and can't be remotely woken up (either via a local print job, or a cloud print job), then the static IP workaround doesn't help. 

 

 


@bruceadler wrote:

If assigning a static IP address problem fixes your wifi-connected MX922 then you got lucky and don't have the same problem as other people have with their wifi-connected MX922s. My printer has had a static IP address since its very first day and it still randomly loses its wifi connection after going to sleep. In other words, if you've got a MX922 which goes to sleep and can't be remotely woken up (either via a local print job, or a cloud print job), then the static IP workaround doesn't help. 



Static IP - Inside or outside the DHCP pool...  doesn't matter.  If you reseve the IP by the devices MAC address the router will always give that device, and no other the designated IP. Use whatever scheme your device supports.

Setting a static IP address for a network device is by no means a "workaround".  Its standard practice in the industry and manditory for successful network administration and management.

The same rules apply for consumer networks powerd by soho and pro-sumer grade networking equpmemt.  The consumer grade boxes provided by comcast, charter, time warner, verizon, AT&T, etc. are junk.  These companies are not concerned about providing you with a robust secure network...  they are selling you TV, phone and internet at the highest profit margins possible.  That includes making you rent their garbage networking equipment on a monthly basis.  Don't expect much from these devices. 

So your statement, " if you've got a MX922 which goes to sleep and can't be remotely woken up (either via a local print job, or a cloud print job), then the static IP workaround doesn't help." is not something I'm going to bother debating.  You must have a unique environment the fundemental rules of networking don't apply to.  If you cannot ping your printer using its statically assigned IP 100% of the time, I suggest you look at replacing the equipment powering your networlk.

 

From your post, I see clearly that you have a deeper understanding of networking, but if your equipment doesn't retain ARP information correctly, it's pretty worthless.  

~Rick
Bay Area - CA
~6D2(v1.1.0) ~Many Lenses ~DxO PhotoLab Elite ~Windows10 Pro ~EVGA RTX 2080 FTW3 Ultra ~ImageClass MF644Cdw

I recently developed this problem.  After trying numerous items suggested in this message string, I called Canon Customer Support.  They recommended resetting the router, which did nothing.  Then, I ran the Canon network utility and it identified a problem with the port on the computer.  I corrected that problem and the WiFi disconnect problem is gone.

 

I've been following this thread briefly, having had this very problem on a friend's MX922, again and again.

When I leave, their printer is online and working, the next hour or day it is not.

 

I defined the static IP long ago, believing this would finally do it, but it had no lasting effect.

 

I have to agree with the analysis and conclusions of bruceadler throughtout this thread.

 

I defined a static IP for my wife's MX882, at about he same time I did that same chore for my friend's MX922.

The MX882 had occasional offline issues, but none since the static IP was  defined for that printer.

 

The MX922 seems unfixable, though I will try to find the "LAN drx" settings when I have my next chance.

Thanks to all who contributed to the discussion.

 

CM King 

spirestocks
Frequent Contributor
Genius post, I hope the take heed develops roots. Perhaps Canon can use your post on the top of the list and consider the issue solved and educate/train forum personnel/help line, noting, because routers are not issued by Canon, the user will have to perform this fix themselves. Well done for being able to explain so well.

dgkerr53
New Contributor

First thing I did when I bought this printer is assigned a static IP to it.  I always have to turn the printer off and then on again after I send a job to it if it's been idle more that a couple of days.  I'm looking forward to dumping this sorry printer in the near future.  

View solution in original post