cancel
Showing results for 
Search instead for 
Did you mean: 

MF644Cdw vs, Pixel 4 Phone

CBFPD-Chief115
Contributor

I cannot figure out how to get the phone to find the printer. This started when I found that Amazon Alexa could not find the printer, and went on from there. I had two long support calls, one with Amazon, one with Canon, to no avail. It was during the Canon call that I realized that the phone was not able to discover the printer, not that it was an Alexa failure.

I have searched the Internet at length, and nothing there has helped.

I asked for a Pixel Phone support call-back, which never eventuated; after two hours, I gave up and have yet to try again.

Canon Print is installed, which worked well with my now-replaced Brother printer.

I have several other printing apps on the phone, all of which identify the printer, none of which actually do anything such as putting a print command into a browser.

Is there perhaps a setting in the printer which needs to be changed? Is there perhaps someone here who can solve this quandary?

1 ACCEPTED SOLUTION

Solved: Another on-line search for instructions turned up a very simple way to get Canon Print Business to find the printer.

One problem solved, leaving only "X to the Nth" more to go....

View solution in original post

7 REPLIES 7

CBFPD-Chief115
Contributor

I forgot to to state that the phone and the printer are both on the same WiFi setup. We can print from both computers, third-party programs, such as a scanning program, can access the printer; it is only the phone which cannot do that.

Hello,

When using the printer from an Android device, you can use our Canon print business app to send documents to the printer. Once the app is installed and opened, allow any access request for the app so it can search for the printer properly.

The Canon print service is a plug in for the Android OS. The plug in works with the print system on the phone to allow you to print from other apps. Once the plug in has been installed, you can go into the settings of your phone and access your printer settings. In the list of printer services installed on the phone, you can turn the Canon print service on. Once it is installed, any Android apps on the phone that use the Android print system can now communicate with printer. The Print service will not add the print command to any apps, but it will let you use the print command that is already in apps that support printing.

We would be happy to assist with the issue. To provide some feedback or some troubleshooting steps, we would need some additional information. If you could reply to this message with the information below, we can provide some assistance.

  1. Is the Canon print Business app able to locate the printer?
  2. What app are you trying to print from on your Android device using the print service?
  3. What version of the Android operating system do you have on your phone?

I regret to inform you that Canon Print Business reports "No printer", even when I am looking at the Canon MF644Cdw printer which works very well from both my wife's and my computers.

Yes, the Pixel 4XL and the Canon MF644Cdw are on the same WiFi, but so far I have been completely  unable to get the two devices to talk to each other.

I don't have any idea what this is trying to tell me, but Canon Print Service, for example, finds the printer, showing both its model information and its 192.x setting, but that is all it and other similar programs do, which is not useful as none of the actually produce a print command in Fire Fox/Chrome/Edge.

I am not sure how I found the instructions to use the QR code on the printer to get Canon Print Business to find the printer, but I have tried a few times to get that to work. The process stops with a rather meaningless error message to check the Send settings. That is meaningless as it does not say what specific entry or entries to check, nor what they should be changed from to.

My frustration continues, sigh.

Solved: Another on-line search for instructions turned up a very simple way to get Canon Print Business to find the printer.

One problem solved, leaving only "X to the Nth" more to go....

Please tell me that this is not so: A few hours after getting Canon Print Business to work, even though it says that the printer is ready to work, I no longer have a print command while reading articles in browsers.

To say that this is aggravating would only be to state the obvious. Therefore, consider it having been stated.

CBFPD-Chief115
Contributor

Further entertainment: I have found that the Scan command works, and that the command to print the resulting .pdf works. I have also found that the printer-ready (green) setting keeps changing to yellow (that seems to have just stopped.)

Printer may be ready, except that there are no print commands in browser articles. This is known as "Ready, Set, Do Nothing."

Announcements
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
06/07/2022: New firmware version 1.0.3 is available for EOS M50 Mark II
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version 1.0.5.1 is available for EOS-C500 Mark II
05/26/2022: New firmware version 1.0.3.1 is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version 1.0.1.1 is available for EOS R5 C
03/23/2022: New firmware version 1.0.3.1 is available for EOS-C70
03/22/2022: New firmware version 1.2.0 is available for PowerShot PICK
03/16/2022: New firmware version 1.5.2 is available for EOS-R5
03/16/2022: New firmware version 1.5.2 is available for EOS-R6
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.1.1 is available for EOS-R3
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/19/2022: READY FOR ANYTHING EOS-R5 C
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.
01/05/2022: Welcome to CES 2022!
12/7/2021: New firmware version 1.3.0 is available for Mount Adapter EF-EOS R 0.71x
12/7/2021: New firmware version 1.1.1 is available for CR-N 300
12/7/2021: New firmware version 1.1.1 is available for CR-N 500
12/2/2021: New firmware version 1.1.0 is available for RF 70-200 F4 L IS USM