cancel
Showing results for 
Search instead for 
Did you mean: 

shutter release not working S100

sandysorlien
New Contributor

Hello,

I am suddenly having problems with my S100. It will not take the picture when I press the shutter release. In case I had accidentally changed something, I did a Reset to Defaults. Then it worked, briefly, before returning to not working. It also would not let me change My Colors.  Everything else seems to be working fine.  Any ideas?

574 REPLIES 574

Danluckett
Frequent Contributor
There was a recall on the lens error issue, but I don't know of any recall for the shutter issue.

msostrowski
Occasional Contributor

Hello,

 

I have not posted in awhile and I did not read the continued postings on this thread, but I thought I would update my status.

In December 2014 I took my camera apart and I did use the DeOxit on the shutter release button internally.  The camera really has worked well up until last weekend.  Unfortunately I now get the lens error message and the camera will not work.  I called Canon and my camera's serial number is not part of the lens recall.  I have given up and I will not try to fix the camera at this point.  I was happy with the camera except having these two major issues.

 

I bought my wife a DSLR yesterday to replace this camera.  A size difference I know but it will not have the lens error potential.  It will be nice to have a good camera to take some good quality photos.  I always have my iphone with me for the times I dont plan on taking photos anyway.  For me this was the right decision, but unfortunately for the readers of this thread it may not be what they wanted to hear.

 

Good luck everyone... up yours Canon!

Danluckett
Frequent Contributor
Try spraying deoxite externally on the shutter button, with the button depressed.

John_
Respected Contributor

Those lens assemblies new go for cheap money like $20 but you'll have to take the camera apart again if you've not completely given up already

msostrowski
Occasional Contributor

Thanks John,

do you happen to know the part number and where I can buy the part?  I live in Canada

John_
Respected Contributor

If you do a search on an auction site like ebay for Canon S100 lens assembly youll find it I dont have any part numbers for that, I didnt take notice of them..if you call Canon they might provide it for you

Danluckett
Frequent Contributor
You will need the shutter part and the lens assembly. The shutter part is: CM1-7226-000 FPC ASS'Y, TOP
I suggest calling Canon repair parts 866-481-2569 and tell them which camera you have and they will help you.

AngelaX
Frequent Contributor
See Goop's message several posts back for the part # etc? I just ordered one from Canon Canada this week. I was told it was out of stock but would be sent within 2 to six weeks, depending on whether the part was to be shipped from the U.S. or China.
Ask for Mike in customer service. I gave him info on the S100 background and the many pages of issues on this board. Or better yet, get another service rep and give him/ her all the reference site the forum info. Maybe we can get a buzz going at customer service.

Danluckett
Frequent Contributor
Hi selfexpert: See my post #361 and other more recent reports. You can fix with an $18 part, or you can report to BBB and may get relief. Good luck.

steadygrip
New Contributor

Hi, I'm having the same problem.  Very frustrating!  I lose important shots!  I've been very happy with the S100 until now.  Time for a new camera?  If it costs $160 just to have the camera looked at, plus the time I'll be without it, it may make more sense to shop for a replacement.