cancel
Showing results for 
Search instead for 
Did you mean: 

shutter release not working S100

sandysorlien
New Contributor

Hello,

I am suddenly having problems with my S100. It will not take the picture when I press the shutter release. In case I had accidentally changed something, I did a Reset to Defaults. Then it worked, briefly, before returning to not working. It also would not let me change My Colors.  Everything else seems to be working fine.  Any ideas?

574 REPLIES 574

Danluckett
Frequent Contributor
AngelaX, just order the part and find some handy teenager (who has changed the screen on a cell phone) to fix it for you in exchange for ... something.

AngelaX
Frequent Contributor
🙂 it seems enough people are having luck with this, so that's a good idea!

Goop
New Contributor

Hello,

 

Just wanted to add my voice to this and thank you people on the forum. I had the same shutter release problem with my s100. I have had it for 3 years and have used it fairly minimally. I had the same experience with Canon wanting to charge $164. I tried to complain but they said not enough people have that problem and that on the internet you will always find people with the same problem but it doesn't constitute a known fault. No luck there so I decided to give it ago myself.  I have no experience taking apart cameras but thanks to the detailed advice on this forum I was able to make it work again. The part number in the camera was 7226-020 but the one I replaced it with was 7226-030. I took the six outside screws out and took off the two sides of the outer assembly of the camera (don't do this too violently as the front part is attached by a thin piece of circuit. Then I removed one screw holding on the top plastic assembly on the side of the camera and one just above the lense. Then I removed the top plastic assembly and removed the two screws that hold the white box thingy on top. It was very cold in my house so the old FPC Assembly came off quite easily. Like others have mentioned the hardest part is to get that slide in connector in. I was really sure I was going to stuff that up but if you just keep trying you will get it in eventually. Anyway to my surprise it worked. I am from Australia and I ordered the part from a website called mediaform. 

 

So to all the people who posted detailed instructions thank you. Also a question: do you guys think that a few years down the track this part will still be available? Or would it be wise to buy another now just in case? The part was 50 AUD with shipping so I am not too keen for that. 

 

Best, G

Danluckett
Frequent Contributor
Congratulations on successful repair. Hard to say about future availability of the part -- or if you will ever need it. The price (with shipping) is about $18 in the US. Maybe you know someone who will be traveling, since you are in no hurry for the backup part. I thought about getting a spare, but will not since who knows what other failure may occur over the next 3 or 4 years -- or what technical obsolescence may occur. For others, the time to order the spare is when you first order the part, since shipping costs the same for one or two, or possibly a few.

My shutter failed same as everyone else's.  I decided to go the replacement route.  Here is a detailed report of

what I did.  Hopefully someone finds it useful.

 

Call Canon parts: 866-481-2569
Request part CM1-7226-000 "FPC ASS'Y TOP" (Flexible Printed Circuit Assembly, top of camera)

Cost is $18 with shipping.

 

Note: The part that was removed from the camera was marked 7226-020 (small writing near selector switch.  The

part that I received from Canon was marked 7226-030.  The packaging and order number were both 7226-000.

 

Tools you will need:
Small philips screwdriver, either "00" or "000" size.
Sharp pick of some sort
Optional: fine tweezers, guitar pick

 

1. Start by removing the six visible screws on the outside of the case.  If your screwdriver fits these you'll

have no problem with the rest.  These screws are all the same length.  Set them aside in one pile.

 

2. Remove the front and back covers.  Be careful when removing the front cover as there is a flex cable

connecting the front adjustment ring to the camera body.  The cover for the USB and HDMI ports will fall off in

this process.

 

3.  I recommend unplugging the adjustment ring flex cable.  This allows more freedom in manipulating the body of

the camera in the next steps without the possibility of damaging the cable.  Before unplugging the cable note how

it flows from the camera body to the front cover with no twists.  This is important during re-assembly.  Gently

pull on the cable to remove it from the white connector on the camera body.  Alternatively you can use your pick

to pull out the connector using the small hole in the cable near the connector.

 

4. Remove the top cover by first removing two screws, one just above the lens and one on the side below the

selector switch.  These screws are different length.  Set these aside in a second pile.

 

5.  Separate the connector behind the flash pop-up.  You can use a finger nail or the guitar pick to do this. 

Look at the new part and it should be obvious how to do this.  The top half of the connector just lifts off.

 

6.  Remove the GPS antenna assembly.  The is the white rectangular block above the lens.  There are two screws

holding this in place.  One is plainly visible, the other is near the connector that was just separated.  You
will need to lift the flex tail that is held in place with a mild adhesive.  You can let the GPS PCB (printed
circuit board) assembly hang.  There shouldn't be much stress on it.  Under the GPS PCB is a metal tray. 
Wiggle that out too.

 

7.  Open the connector that connects the top FPC to the rest of the camera body.  This is done by flipping up the

latch mechanism, which is the black bar on the white connector.  The black bar is on the side of the connector

away from the cable.  Use the guitar pick or a fingernail.

 

8.  Remove the top flex assembly.  Note that the flex tape is positioned by six posts.  Four are plastic, two are
metal.  Lift the flex off of these posts.  In the area of the selector switch the flex is held down by some
fairly aggressive adhesive.  Use the guitar pick to work it loose.  You will likely dislodge one or more of the
components on the flex tape in the process.  There's no turning back now!

 

9.  Install the new flex tape taking care to make sure that it is correctly located over each of the posts.
Insert the tape into the main connector and close the latch.  Snap the two connectors together near the flash. 
Make sure that the focus LED is correctly positioned behind the plastic retainer.  You have to lift it
and slide it down behind its retainer.

 

10.  Reinstall the GPS antenna tray and antenna PCB.  It takes a bit of wiggling to get it in place correctly.
There is a black plastic retainer just above the left side of the lens that holds the GPS antenna flex cable
in place.  Ensure that the cable is behind this retainer.  The shorter screw goes nearer to the flash.

 

11.  Replace the top cover and the two screws that hold it on.  The longer screw goes near the lens.

 

12.  Reinstall the front ring cable.  Line up the cable in the socket and use the pick through the hole to
push it in.

 

13.  Replace the front and back covers.  There is a foam dust ring that goes around the lens (it may still be in
the front cover.  Make sure that this is correctly positioned over the lens.  As you snap everything
together, make sure to include the port cover as well.

 

14.  Replace the six external screws.  Test everything out to make sure it is working properly: shutter,
selector, flash, ring, etc.

Danluckett
Frequent Contributor
jimpgh: Nice write-up. Should help some one muster the courage.

Hi

 

post 40 an excellent repair procedure which helped me replace the faulty shutter button flexi printed cct assembly  on my S100. Couple of small steps could be added.

Firstly remove battery and memory card. Secondly to avoid potential electrostatic damage to camera electronics, and before starting to dismantle camera, discharge any body static charge by touching  a suitable earth point, eg a metal water pipe.

Danluckett
Frequent Contributor

Hi folkymuso

Good additions. I think you meant to credit post number 400, not 40.

Good points about the battery and memory card.

It's not necessary to touch a water pipe though. As long as you touch the body of the camera when you start you will be in equilibrium with it and that's all that really matters. What you should avoid doing however is getting up and walking away from the camera once you have opened it. The internal electronics are vulnerable in this state and walking even a few steps can recharge your body relative to the camera. If you must, when you return I would recommend first touching the metal plate that shields the memory card. This is externally accessible and should be immune to static discharge.

John_
Respected Contributor

wow!!! $400+ !! thats a big investment and now a loss maybe Angela ! so sad this whole S100 mess