cancel
Showing results for 
Search instead for 
Did you mean: 

SX280 - battery life shooting video

factoryguy
New Contributor

UPDATED May 5:

 

I apologize to the forum for mixing two different problems.  They are unrelated.

 

Problem #1:  User error.  I thought I was using a class 6 SD card but I was wrong. The yellow "!" indicates a pathologically slow card.  Upgrading to a class 10 resolved this problem.

 

Problem #2: UNRESOLVED.  Red battery indicator comes on prematurely.  On a fresh charge, it'll turn red after recording for a couple of minutes.  On a partially drained battery, it turns red immediately upon entering movie mode or pressing the record button.  Turn the camera off and then right back on in "still" mode and it shows full charge and works fine ... until trying to shoot video.  I have not precisely measured recording times but it'll record for at least 20 (maybe 30?) minutes while flashing red.

 

 

 

1,334 REPLIES 1,334

canonuser4
Occasional Contributor

Mine was returned yesterday. I'm tired of dealing with it. It was the second sx280 I tried.

dswansonil
Frequent Contributor

Coming up on the ned of another week.   Price and rating on Amazon are dropping.

 

Any bets on getting a message from Jessica that Canon is making progress and please continue to be patient? 

RCJ
Frequent Contributor

Yeah, starting to lose patience. About to call vendor and challenge 30-day return policy as the product is flawed.

My Canon experience:

2x different IXUS

Canon EOS 500D

Powershot SX200

 

Update on my post few days ago.

 

I tested the battery life again but now in 2 different ways, with both times a full battery to start with.

 

Conditions in both tests

Eco mode turned ON

GPS turned OFF

WIFI turned OFF

Not using flash

 

Test 1 = Max. video length without taking pictures or zooming

I had the camera set on a tripod and did not touch it except for the ON/ OFF video button.

The next thing I did was, turn the video ON for 3 minutes followed by 1 minute OFF, and doing this continuously till the battery gave up.

This was after 15 times, so 15 times ON x 3 min. = 45 minutes video!

Immediately after this I removed the battery and measured the temp. and it was 49 deg. Celsius.

I was satisfied and thought I made a mistake the first time, but the temp. of almost 50 degr. Celsius of the battery was disturbingly high.

(every 10 deg. celsius above 30 deg. celsius shortens the battery life by factor two for Li-on.)

 

Test 2 = Normal use for me on a holiday

I did a short research on my last holiday pictures and came up with video-shots from 10 sec. to 3 minutes and between the video shots mostly 10 to 20 images.

So in a time period of one day I used the camera as if I where on a holiday.

The result was: 120 images and an added total of 9 minutes of video until the camera shut down during a video-shot because of an empty battery.

 

My solution

120 images and 9 minutes of video could be useable, however not for me and especially not on a holiday.

So I'll take it back to the store because my returning-window is closing soon and I am not expecting a solution for this problem other than: adding more battery power or lowering the processor speed.

If the indicator was giving the actual power left in the battery AND the battery did not cost as much as 45 euros I think I would have kept the camera.

 

Good things

The pictures are really good, clear and have very little noise.

You can shoot indoors with 20 times zoom and still get very sharp pictures without noise and distortion considering the high ISO values.

And the videos are very steady and clean.

 

Bad things

Aside from the huge battery problem:

The encoder-wheel is turning quite heavily so you're accidentally pushing it too hard so the flash is popping up frequently while you are altering other settings.

The mode selection wheel or switch is turning quite heavily as well, hence at least it won't turn by itself when you put the camera in the camera bag.

 

I have spend days, looking for the best camera in this category and figured out that the SX280 is by far the best.

Looking at my footage it is far beyond my expectations however sadly I must return it.

It's like giving someone candy and after 10 sec. you take it back.

 

 

 

 

dswansonil
Frequent Contributor

canon_user,

 

Great analysis!  Given your experimental procedure and knowledge of thermal effects on the battery, I'd guess you might be an engineer. 

 

Your first test on a tripod would seem to confirm that the image stabilization is NOT a significant power drain as the documentation indicates that it is de-activated in that shooting mode.  I know in earlier cameras it was supposedly a big draw on the power supply.

 

Your second test confirms that battery life is terrible even under normal shooting conditions as 120 images and 9 minutes of video is way too limiting.  I imagine that your second test also simulates what was not in the first test in that you were probably turning the camera on and off and zooming to take pictures. 

 

I would have expected that the lens motor was an major demand on the battery but that is a part of the standard CIPA battery life test:

 

"Under the test scheme, the camera takes a photo every 30 seconds, half with flash and the other without. The test zooms the lens in and out all the way before every shot and leaves the screen on. After every 10 shots, the camera is turned off for a while and the cycle is repeated."

 

That would seem to parallel your second test and lead one to believe that 9 minutes of video consumed about half of the battery's available power (210 exposure rating).  As a point of reference, the standard battery for the Canon Vivia camcorders has a slightly lower power rating (890 vs 1000 mah) but seems to produce 90+ mins of video.  They use a different processor so it looks likely that's what takes all the power.

 

Bottom line is then as you stated.  It's unlikely they can fix the underlying battery life problem without increasing the battery's power rating or decreasing the current draw by hobbling the processor.

Gus
New Contributor

Well I purchased the Sx280 for my daughters birthday three weeks ago.   Her first new camera and she wanted to use it for a school project  Video and stills.    We discovered the video issue right away, and I saw that canon was working on a firmware update.   So since she loved the stills...  I loaned her my new SX50 to shoot the video for her project and waited for the firmware fix.

Just downloaded the fix today...    I had not followed any of  the posts here as I just assumed it would fix the problem.   

With new firmware and a full battery...   I get 2 1/2 to 3 minutes of video before the light flashes.  With my camera it only seems to go another 30 secs and the camera shuts down in the middle of a video shoot.   I can then switch to any camera mode and turn on the camera and it shows full battery power.   Switch back to video and it does maybe 30 seconds and it shuts down again.

Sadly I am past the 15 day window of return with Bestbuy..   (although I am going tomorrow to try and get my money)  I am past the 15 days because in good faith I assumed that if Canon said they had a firmware fix, that they really did.  My young daughter loves the camera part of this 280, as do I.  But since she wants to shoot video of her and her friends...  
I really wanted this to work.   I love my SX50 and was hoping this 280 would be as nice for her.

So if anyone is really counting...    I did the firmware and have seen no real improvement in the video / battery issue.

Thanks
Gus


 

completelocks
Occasional Contributor

getting annoying this is now.... I turned subscriptions off, it says no posts to show. Yet, I get back from my hols to be greeted with over 100 emails from this site telling me about posts on this thread.

How the hell do I delete my account?

 

completelocks.

 

Here, here. I have the very same problem, unticking all the options didn't do anything, so I complained to Admin - that didn't do any good either... so what did I do?

 

I went into my settings and reset my Email to anything but not mine. I don't like doing this but I was receiving Newsletters I didn't ask for , since my complaints fell on cloth ears what else can I do? 


This was after I was told it would be looked into.... just like their SX280HS I guess.

 

Dave

tprevett
Occasional Contributor

So I made my first significant use of my SX280 yesterday, taking 703 pictures as well as multiple videos.  Pictures look great, however, There are still some quirks with video (I did get 24 minutes as you can see in a previous post)..  but I have come to the conclusion, that if the battery is anything less then 100% full when you start recording video, it seems that you will get the red flashing battery almost immediatly and the camera will shutdown.. 

 

It's not perfect, but the pictures are incredible for what it is!.. I guess ill leave video to my Canon XA10

 

Picked up the Wasabi batteries and charger too..  I could have probably used a single battery to capture the 650 or so pictures.. a lot of the pictures were multiple burst photos.. all in all I'm pretty happy with the battery life for taking pictures.

tprevett: Just to clarify for other users still experiencing problems (and Canon, which has been monitoring this thread), the firmware update did NOT fix the video problem on your camera, right? That is to say that anything less than 100 percent charge, you get the flashing red light and the camera shuts down prematurely. Correct?