cancel
Showing results for 
Search instead for 
Did you mean: 

Can't connect SX350 to laptop.

z8000783
New Contributor

Some help required please especially from Canon if they are around.

I have a Lenovo Windows 10 laptop and have installed the Canon utility to download my photos.

So I then run the camera function to make the transfer but, as it's the first time I need to 'Add a device'.

Eventually the 1-2 minutes, the camera finds the laptop correctly and then starts serching for the device which it then never finds. Is there something I am doing wrong.

Points to note:

I am standing next to the router with the camera and laptop. I have restarted the laptop a number of times and reinstalled the software.

Please don't ask if I have tried it wih a USB lead, I don't. I bought the SX350 because of its wifi connection and don't see why it shouldn't work.

 

Many thanks all.

4 REPLIES 4

Jenine
Super Contributor

Hello Z800783!

 

Welcome to the Canon Forums and thanks for your post!

 

The PowerShot SX350 is a non-USA model, however the troubleshooting steps we would suggest for an USA model are: check to be sure the date and time on the camera are correct. This could effect the connection. Also, make sure the proper Microsoft Services are set to "started" on your computer. This has to be done in order for the camera to be recognized by the computer. If you are in the USA and need additional assistance, please contact our Technical Support Team at 1-800-OK-CANON (1-800-652-2666). They are open Monday through Friday from 10 AM to 10 PM ET, excluding holidays. If you are not in the United States, please go www.canon.com and choose your region.

 

We hope this helps! 

Thanks Jenine

 

Sorry for using the wrong forum but I couldn't find one for Europe. If there is a link can you let me have it, please.

Yes the date and time are all correct. I didn't set any specific sevices on windows for the camera when I installed it, what services do I need to be running.

 

Regards John

Jenine
Super Contributor

Hi z8000783!

 

You're welcome! For information on Support and which Windows Services need to be turned on for your camera please contact Canon Europe at www.canon-europe.com. 

 

We hope this helps point you in the right direction! 

Problem resolved thatnks to some great and patient support from Canon Europe.

Good stuff guys.