cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

MAXIFY GX4020 Constantly Offline

dizzlelizzle
Contributor

My GX 4020 constantly goes offline and I'm not able to print from any device.  It it wireless, has a static IP address, and I changed the power settings so it is always on, but 90% of the time when I try to print it is "offline".  When it is "offline" and I try to access the web interface for the printer, it either does not respond, or is very slow to respond.  When I am able to print and try to access the web interface it is very responsive.  The firmware is up to date.  Any help would be appreciated.

17 REPLIES 17

dizzlelizzle
Contributor

I forgot to mention that power cycling the printer fixes the problem makes the printer appear online for a little bit.  Just about every time I print I need to power cycle the printer.

shadowsports
Legend
Legend

Greetings,

Assigning a static IP is typically one of the best ways to ensure persistent connectivity.  

If you have that set, then you should be able to ping the device from a command prompt or terminal.

Where did you set the static IP? 

Other issue might be power, sleep or ECO settings.  

~Rick
Bay Area - CA


~R5 C (1.0.6.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

I can ping the printer, but some of the requests time out.  It is very inconsistent.  I'm very confident it is not a network issue because I have numerous other devices on my local network with static ip address (outside of my DHCP address range) that don't have this issue.  

dizzlelizzle
Contributor

I set the static IP on the printer itself and I verified it always has the same IP address.  What are the power, sleep, and ECO settings that I can take a look at and what should those values be?

Thanks.

shadowsports
Legend
Legend

Greetings,

Try setting the IP you reserved for the printer on your router.  Here is an example.  I use 1.99 for my printer.  

Router:

Router - Reserve IPRouter - Reserve IP

Printer:

Static IP_Printer.png

Test Ping

ping_reply.png  

Why you want to do this.  After a period of inactivity, (device turned off, sleeping, not used for an extended period) the router could assign the IP for the printer to another device.  This might happen if the lease for the IP expires, or if no communication between the two occurs for a period of time.

If this happens and you try to print, the device will show as offline because its sending a print job to a destination it believes is valid, but has actually changed.  You mentioned that restarting the printer restore printer function typically.  

Optional, you can leave DHCP enabled on the printer, if you reserve an IP on your router.  Its responsible for managing and maintaining IP's not the printer or device. 

Power Settings: (if issue is related to power settings)

Canon : Inkjet Manuals : GX4000 series : Managing the Printer Power

Set to Auto Power On

Auto power on: When you check this check box, the printer automatically turns itself on when data is sent.

IJ Network Assistant Tool:

  • When the printer is turned off, the Canon IJ Status Monitor message varies depending on the Auto Power On setting.
    When the setting is Enable, "Printer is standing by" is displayed. When the setting is Disable, "Printer is offline" is displayed.

 ECO Settings:

Canon : Inkjet Manuals : GX4000 series : ECO settings

  • Selecting Do not use power control disables all settings of the power control and scheduling.

Please make these changes and see if this helps.

~Rick
Bay Area - CA


~R5 C (1.0.6.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

I made all of the changes you suggested and I’m having the same issues still. I cannot print but when I ping the printer I’m getting very erratic responses from 100ms to 3500ms to timeouts (greater than 4 seconds).  This is definitely an issue with the printer responding to request and not my network. What should my next steps be?

dexman335
Rising Star
Rising Star

I'm not familiar with the 4020 (I own an imageCLASS MF743), so here are a few basic questions & thoughts.

Is the unit receiving a strong Wi-Fi signal?

If the unit has the ability to be factory defaulted, it might be worth trying it. Otherwise, I'd give Canon Support a call to see if they can determine if the unit needs to be serviced.

It is 5 feet from the router and has a 90%+ signal. I’ll try contacting support. I read about this issue before purchasing the printer thinking it was user error.  I was wrong.  I would not purchase this printer again. If support somehow fixes the issue I’ll reply to this, but it isn’t going to happen. I had the same issues with a previous canon printer. 

dexman335
Rising Star
Rising Star

Let us know what happens. 🙂

Announcements