cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS webcam utility showing usb and red "x"

bgadbaw
Apprentice

I recently bought a used Canon M50 Mark II to use as a webcam and am getting the dreaded usb with red "x" icon on zoom and OBS. I've read several threads on this issue and tried many of the obvious and less obvious solutions (turning off wifi on the camera, trying different USB cords, formatting the memory card, putting the camera in video mode) but I'm still stuck. Help? I have a mac Mini running macOS Sonoma 14.1.1 on an Apple M2

Screenshot 2024-03-01 at 9.27.05 AM.png

IMG_1639 2.JPG

IMG_1642 2.JPGIMG_1641.JPG

3 REPLIES 3

kvbarkley
VIP
VIP

Have you tried the new version? 2.1 just recently dropped as the cool kids say.

bgadbaw
Apprentice

Thanks for the reply. Yeah, I'm running EOS webcam utility pro version 2.1.18. 

Screenshot 2024-03-01 at 11.09.09 AM.png

Solublepeter
Contributor

I had issues some time after I changed to an M- series Mac- The beta and first release of the Canon webcam software ran in backwards-compatibility mode (where it emulates an Intel-based Mac), but as this was triggered when using OBS, all was OK.

When OBS was upgraded to properly support the M series chips, it no longer ran in compatibility mode, so the webcam software stopped working.

The later Canon software was written to work with an M series chip (perhaps the "Pro" software denotes this change) 

So check which webcam software version you are using. The newer one is the one that tries to encourage you to subscribe to work with higher resolutions. Both were still on the website when i last looked.

I hope this helps someone, if not you 🙂

 

National Parks Week Sweepstakes style=

Enter for a chance to win!

April 20th-28th
Announcements