Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS Webcam Utility *breaks* QuickTime movie capture on M1 Max


I often use QuickTime to capture my iPhone 12 Pro Max or iPad Pro to then bring into OBS for live streams of games like Fire Emblem Heroes. Up until recently, this worked fine, and I would use EOS Webcam Utility to get a clean feed from my Canon 70D into OBS as well.

However, recently, something seemed to be breaking QuickTime. Loading it up via Terminal revealed that QuickTime automatically trying to load EOS Webcam Utility (since it's identified as a webcam) when trying to do a New Movie Recording is what is breaking it. It is trying to load an x86_64 library when it is looking for a compatible arm64 library.

Again, this setup worked as of yesterday, but it seems 12.3.1 is now requiring an ARM-compatible library. EOS Webcam Utility has not been updated for Mac since before M1 chips were launched. Any chance we can get an update for M1 compatibility? Otherwise, I can't capture my games natively without uninstalling EOS Webcam Utility, but then I can't capture my 70D cleanly. I have an Elgato Cam Link 4K I could use, but the 70D doesn't export a clean feed via HDMI.

~ % /System/Applications/QuickTime\\ Player
2022-03-31 ... QuickTime Player[4344:44616] Error loading /Library/CoreMediaIO/Plug-Ins/DAL/EOSWebcamUtility.plugin/Contents/MacOS/EOSWebcamUtility:  dlopen(/Library/CoreMediaIO/Plug-Ins/DAL/EOSWebcamUtility.plugin/Contents/MacOS/EOSWebcamUtility, 0x0106): tried: '/Library/CoreMediaIO/Plug-Ins/DAL/EOSWebcamUtility.plugin/Contents/MacOS/EOSWebcamUtility' (mach-o file, but is an incompatible architecture (have 'x86_64', need 'arm64e')) 



Before you downloaded and installed the software app, did you check the hardware and software prerequisites?  

"The right mouse button is your friend."
click here to view the gallery