cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS Webcam Utility Pro will not even open window - [addon] error disabling headless mode

DesertShadow
Apprentice

Notably this is a multi-GPU (non-SLI) system, Windows 10

The window won't even pop up, the process hangs around flooding to standard output

  • There are no logs in C:\Users\deser\AppData\Roaming\EOS-Webcam-Utility\EOS Webcam Utility Pro\logs
  • Restarting the computer doesn't fix it.
  • Run as admin doesn't fix it
  • Compatibility mode doesn't fix it


And the only error I get is when running from terminal, here's the output

 

C:\Program Files\Canon\EOS Webcam Utility Pro\EOS Webcam Utility UI>
"EOS Webcam Utility Pro.exe"



[addon] error disabling headless mode

[addon] error disabling headless mode

[addon] error disabling headless mode

[addon] error disabling headless mode

[addon] error disabling headless mode

 

5 REPLIES 5

Waddizzle
Legend
Legend

Do you have a subscription to use Webcam Pro?

--------------------------------------------------------
"The right mouse button is your friend."

No, but there should at least be a display that pops up with options to add license info. Also, there is a free version that I typically use that I expected it to fallback to

lotusgg
Contributor

Hello, I have the same issue. App opens on the background, never shows up. Can only see it running on the task manager. If I try to launch it via powershell terminal, it also returns the same error over and overe every second. "

[addon] error disabling headless mode

No log whatsoever is generated, and returns no error message. Tried uninstalling, reinstalling and even format the pc and install every visual c runtime and directx up to date but it still didn't work. 
Funny tho, it worked on the other pc.
And yes, I have the subscription. The app just doesn't open.

NatalyaP
Product Expert
Product Expert

Greetings DesertShadow,

Thank you for the information you've provided with troubleshooting the EOS Webcam Utility Pro software. In case you haven't already done so, please uninstall the software and re-install it. Please also check to see if there may be any security software or security settings in Windows 10 that is preventing the app from running.

Please check to see if the software will run when using a computer running with Windows 10 and with only one GPU.

Hello NatalyaP, I have the same issue as OP, only difference is that I'm running a single GPU system (AMD). As for reinstalling, I have tried that many times, on a windows 10 system with Kaspersky and then on a fresh windows 11 installation, so there should be nothing preventing it but the issue persisted. No matter how many times I reinstalled it or rebooted the pc. 

National Parks Week Sweepstakes style=

Enter for a chance to win!

April 20th-28th
Announcements