Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS Webcam Utility (2.1.18) not working with MS Teams 2024


I've been using the paid version of EOS Webcam Utility Pro (2.1.18) to stream over Teams until today. After updating Teams to the most recent "version 24004 (24004.1204.2655.7488)" EOS Webcam Utility no longer recognizes Teams is actively streaming my camera. 

It's not a Teams issue, as Teams still displays EOS webcam utility feed as it should, albeit the "off air" fallback image. You can see this in a side-by-side screenshot here: My camera is active in EOS on the left. Teams is actively streaming the EOS feed on the right, but EOS doesn't understand the stream started yet.

Screenshot 2024-02-13 at 2.37.58 PM.png

Please advise on steps to remedy, or confirm this is an active bug you are tracking with EOS Webcam utility (2.1.18)





“ I've been using the paid version of EOS Webcam Utility Pro (2.1.18) to stream over Teams until today. After updating Teams to the most recent "version 24004 (24004.1204.2655.7488)" EOS Webcam Utility no longer recognizes Teams is actively streaming my camera. “

Did you reboot your computer after the update?  I’m not saying that is “the fix” but it is something you can try.  Otherwise, I recommend updating the Webcam Utility, too.

If all else fails, contact Canon Support about your paid subscription no longer working.

"The right mouse button is your friend."

Thanks for your reply. Yes I did restart my machine after installation, and unfortunately there are no further updates to be made. (Both Teams and EOS Webcam Utility are running the latest versions)

I wasn't thinking about it through the lens of my subscription not working, but good idea. That might be the best way to expedite a response.


I have both macbook, and Imac running Sonoma and an old Imac running High Sierra. In High Sierra everything works fine. 

Product Expert
Product Expert

Hi macbook-amateur,

To fully trouble shoot this issue we would need to know what operating system is on your computer and what camera you are using with the EOS Webcam Utility. It would also be helpful to know how you are connecting the camera and computer.

There are a some general things to check. I see you already tried restarting the computer. One thing to note with that is if you have pending operating system updates and those didn't go through that can cause this kind of issue. If you do have pending operating system updates we would recommend allowing those to go through and then check to see if the same thing is happening.

Another thing to check would be to try opening a different streaming or conferencing program and check to see if the same communication issue is happening there. That can help narrow down if this is specific to Teams, or if it is a more general issue with the camera and computer not communicating. 


Still not working for the latest Teams 2024 (attached). Verified the latest iOS (attached) and confirmed it works on Google Meet (attached). Also adding Mac version/computer (attached). Seems like every update Apple makes, Canon crashes. It used to not be that way. I do love using my 5DMK4 for a webcam but its frustrating when it doesn't work when I expect it to. Please advise and thank you!Screenshot 2024-03-15 at 9.55.40 AM.pngScreenshot 2024-03-15 at 9.56.31 AM.pngScreenshot 2024-03-15 at 9.57.08 AM.pngScreenshot 2024-03-15 at 10.04.32 AM.png


“ Seems like every update Apple makes, Canon crashes. “

Actually, it has always been this way.  This forum has numerous posts complaining about an Apple update breaking the Canon apps.  It has been this way for many years, and it affects other camera manufacturers, too.  

It is not in Apple’s best interests for third party camera apps to work.  Apple would much rather you buy your next camera from Apple, in the form of the latest and greatest iPhone.

[EDIT]. Please start a new thread for your issue.  It is confusing when other members jumpe in.  A separate thread puts your issue at the top of the page, not buried in the middle somewhere.  

Thanks, ahead of time!

"The right mouse button is your friend."

Easy. My issue is directly related to this thread and I'm replying to Hazel_T as she asked for details specific to the problem. There's no need to post a new thread. All of the other users in this thread have the same issue. Thank you for understanding.

Greetings msoverland,

If you're experiencing the same issue as macbook-amateur where the EOS Webcam Utility is showing the live feed from the camera, but it is not showing in MS Teams, then let's check to see if the camera's LiveView function or video signal is being used by another application or software. For example, if there is a photo or video streaming app on your macOS computer that is running.

We recommend exiting and close any applications that may be running on your computer, or in your task tray that may be connected to your camera or using the camera’s LiveView video signal.

Thanks Natalya. I confirmed that there are no other applications running that would need to use the camera and it is still not working. I'll note in the past; however, this wasn't an issue.

National Parks Week Sweepstakes style=

Enter for a chance to win!

April 20th-28th