cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to transfer images from my Canon Rebel XTi to my iMac.

whitneyford
New Contributor

I am unable to transfer images from my Canon Rebel XTi to my iMac OS X Yosemite (10.10.5) using the cord provided with the camera. I know my computer recognizes the camera. I can put them on my Windows laptop and get them off and then transfer with a thumb drive but I don't have time to do that every day. 

3 REPLIES 3

John_B
Super Contributor

Welcome to the Canon Forums and thanks for your inquiry!

The Forums aren't meant for immediate assistance, but are designed to allow the community to help each other with issues encountered or tips they'd like to share along the way.

If this is a time-sensitive matter, our US-based technical support team is a much more efficient way to get help! They're ready to help 24/7 via Email at http://bit.ly/EmailCanon or by phone at 1-800-OK-CANON (1-800-652-2666) Monday-Friday: 8:00 am to 12:00 am, Saturday: 10:00 am to 8:00 pm

Read through this thread and see if it helps. If not, report back with the steps you are using and any error messages that pop up.

 

http://community.usa.canon.com/t5/EOS-Rebel/How-do-I-upload-pics-from-my-Canon-Rebel-T5-to-my-MacBoo...

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, MX472, LR Classic

TCampbell
Esteemed Contributor

Is your cable connected directly from camera to computer with no USB hub involved?   I have gone through probably three or maybe 4 different USB hubs before I actually found one that works reliable with all devices (there's a lot of junk on the market).  But connecting direct to the USB port should work.

 

You mention that you know the comptuer recognizes the camera.  How do you know this?  Are you looking at the "System Information" app (it's found in the "Applications" -> "Utilities" folder on your Mac) and reviewing the devices that are attached to the USB bus (note that the app only lists the devices that were attached when it scanned the bus.  If you start the app, then connect the camera and power it on, then the camera wont show up in the list unless you re-scan.)

 

What software are you attempting to use to communicate with the camera?  Canon EOS Utility?  iPhoto or Photos?  Something else?

 

 

Tim Campbell
5D III, 5D IV, 60Da