cancel
Showing results for 
Search instead for 
Did you mean: 

T4i camera completely locking up in the ON position?

bigguy841
New Contributor

I have had my Canon T4i for about 4 months now, use ita few times a week as a hobby. Every couple weeks I will turn on the camera and adjust the Ap/Sh/ISO settings to prepare for a shoot and the camera will just freeze or lock up in the spot. None of the buttons or dials trigger any sort of response from the camera and I am not able to take a picture or do anything. Even turning th camera to the 'OFF' position does nothing and the camera remains on with the LCD still lit up but not responding. The only way I am able to get the camera working again is to remove the battery and then put it back in and power it up, at which point it usually works normally. The only time I've had this happen more than once in a day was over Thanksgiving when it happened about 3-4 times throughout the day.

 

I contacted Canon support and was told to first try resetting the camera to default settings, which I did, and if that doesn't work to remove the battery and memory cards and using a pencil eraser to clean off the contact surfaces of those items, which I have not done yet. If it continues to happen, I am supposed to send it in to let them inspect it and decide if if needs repair or replacement. Since it seems random and spread out, it's hard to say whether it's 'fixed' since it did it last week before I re-set the settings.

 

Has anyone had this problem? If so, did you do either of those methods to solve it? If you sent it in, were they able to determine the problem and handle it? I don't want to send it in and be without my camera for weeks only for them to tell me it worked fine for them and there is no problem, since it works fine 98% of the time as of now.

 

Any help would be great!

 

40 REPLIES 40

junenward
Occasional Contributor

I've not had the problem for the last 18 months or longer.  I had it several times in mid 2013 not long after I purchased the camera. I did the firmware update and maybe that fixed it permanently.  Prior to that I simply removed the battery and the EFS lense and then re-installed the battery and lense and the camera worked.