cancel
Showing results for 
Search instead for 
Did you mean: 

My Macbook Pro will not recognize my Canon Rebel T3i when I plug it in. Please help!

aprince1982
Apprentice

I've installed the necessary software from Canon, but no luck. Any suggestions?

64 REPLIES 64


@TCampbell wrote:

It’s easy to mistake the USB cable and use a cable that wont work (and this is probably the most likely cause).

 

Make sure you aren’t using a USB “charging” cable.  A number of devices now use USB cables simply to charge a device and include cables that only have the power pins wired ... the data pins aren’t actually wired.  If you use such a cable, the computer wont see the camera.   The cable needs to have the data pins wired.

 

Some cameras that support WiFi wont show up if the camera is in WiFi mode ... but the T3i doesn’t support WiFi transfers so that wont apply to your camera.

 

 


This was exactly it. I tried 3 different cables and nothing worked until I unplugged the one from my wacom tablet and now it's working perfectly. Thank you! 

I own a EOS Rebel T5i, for years I was able to connect to all of my Macs using the cable that came with the camera. Suddenly none of my Macs recognize the camera. However, Windows 10 will recognize the camera. Note this model is not WIFI enabled. The cable works with Windows. I called support and they said try a new cable? Can someone help?

We’re there any macOS updates between when the connection worked and when it stopped working?

Are they the same computers?

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, MX472, LR Classic

Hi,

I recently updated to macOSMonterey, however, the connection stopped long before the update. 

One mac was not updated and the computer does not recognize the camera.

I just went through the steps to determine if my Mac is recognizing my camera.  It is not showing up in the USB section of the Utility Window.  Can you help me understand why my computer is not recognizing my camera?  This is strange becasue this is not the first time that I am connecting the camera to this computer.  For some reason it just stopped working.  Can you help?

Try running image capture from the Applications Folder

I have same problem....Kindly help at the earliest.
Thanks 🙂

 

P.S. I have Mac OS X Lion 10.7.5 (11G63)

What happens when the computer isn't recongizing the camera? I have a Canon EOS Rebel T6i and I'm using a Macbook pro. I followed your steps but I didn't see my camera on the USB Tree. I have some photos that my school wants to use in the year book, and I'd like to find a way to get these pictures to my teacher before the end of this week! Thank you!

 

Hi rachelktibbs,

 

Thank you for posting.

 

If the camera can't be connected to a computer, it may be because [Wi-Fi/NFC], or [Wi-Fi only]  is set to [Enable]. If this is the case, your camera cannot use its USB or HDMI terminals.

 

To check for this, turn your camera on, press the MENU Button then navigate to the Settings-1 (wrench icon with a single dot). Next, set [Wi-Fi/NFC], or [Wi-Fi only]  to [Disable], then connect the interface cable.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

Solution also worked for my mac mini running Catalina. Thank you.
Announcements