cancel
Showing results for 
Search instead for 
Did you mean: 

For Rebel T3i EOS 600D. The main dial seems to be locked as I cannot turn it. Any suggestions?

Petey
New Contributor
 
6 REPLIES 6

Mykolas
Respected Contributor

Petey,

 

Sorry to hear that your EOS Rebel T3i won't turn on.

 

Please try removing the battery and charging it to its full capacity.  You may also try using an alternate battery.  To ensure the battery has a good connection with the camera, clean the contacts on the battery with a soft microfiber cleaning cloth.  When this is done, put the battery back in the camera and turn the camera on.  If the camera does not turn on, your EOS Rebel T3i will require service.

 

To start your repair process, you'll need to complete a Repair Request on our website.

 

If this is a time sensitive-matter, additional support options are available at Contact Us.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

Petey
New Contributor

Thank you. I will try this, however, the problem is not that the camera will not turn on. The"main dial", as it is referred to in the manual used to change the fstop and shutter speed, immediately behind the shutter button that will not rotate either left or right. It seems to be locked or stuck. Any ideas about this?

Richard
Product Expert
Product Expert

Hi Petey,

There's really no reason for the Main Dial to be stuck.  There's no locking function.

 

Regrettably, your camera will require service to correct this issue.  You may set the repair of your camera here.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

Petey
New Contributor

I wonder if it ever worked because I haven't had the camera that long and always used it on auto until recently. Unfortunately it is too late now as it is no longer under warranty. I will have to check into getting it repaired. Fortunately I discovered that the Q button also allows me to change shutter speeds and F stops. Thank you.

TimT
New Contributor

I'm also having this problem with my T3i, 3rd one, same problem with all of 'em.  Dial turns but just stops functioning... sometimes I turn it on and off and on and off and wait a while, fixes itself.  Sending it in for service, junked the last one.

Johnosurfbeatz
Occasional Contributor
Hey guys. Older post I see. Did you find out what was the problem.

I replaced the whole top of my Canon600d/ T3i myself.
The main dial was not jammed. It flowed freely but didn’t do its job, after changing it over.....it still didn’t. May have to investigate the Q button