cancel
Showing results for 
Search instead for 
Did you mean: 

Flash pops up but does not actually fire!

jannatulahmed
New Contributor

Hi everyone, so this problem has been going on for more than a year now. It started happening after my camera experienced some water damage. The camera is able to sense when flash is needed but each time, the flash pops up but the actual light itself does not go off. As I keep the button pressed down it just says "busy". Is this because of the water damage? How can I fix this problem?

 

Thank you!

5 REPLIES 5

John_
Respected Contributor

Yep looks like the water did it and it is not a coincidence but have you done a full reset to defaults with your fingers crossed?

John_
Respected Contributor

What model camera is it? There are a lot of people here smarter than I that might know of some obscure setting that could be causing your problem

Its a Canon EOS Rebel T6i and no I have not done a full reset!

It is possible for the flash tube to burn out.  It has to be replaced by Canon which you should call at 1 (800) 652-2666.

However, they will not be happy when you tell them it got wet.  Cameras and water don't react well together.

EB
EOS 1DX and 1D Mk IV and several lenses!


@jannatulahmed wrote:

Its a Canon EOS Rebel T6i and no I have not done a full reset!


You are very fortunate that the water seems to have only damaged the strobe element, or its’ associated charging and control circuits.  The camera can still take pictures, so it is good to go.  The onboard strobe is pretty weak, and not very useful, anyway.  

 

I suggest that you buy an external flash. It would be cheaper than a repair.  Hopefully, the external flash shoe is still functional.  If not, the external flash would still be useful should you decide to buy a new camera body.

----------------------------------------------------------------------------------------------------------------------------------------------------------

"Doctor told me to get out and walk, so I bought a Canon."