Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS Rebel XS saying busy and won't take pictures


My camera worked fine the other day.  Now, it won't take pictures at all.  When I go to take a picture, it will act like it is focusing by flashing and such but it will never go through.  It always says busy.  I have tried all modes, and none will work not even without flash. 


I have also taken the battery out, taken the card out and reformatted it, and cleared all camera settings.  Can anyone help?  I have a newborn that I would really like to be able to capture. 🙂


Thank you ahead of time!

156 REPLIES 156

scroll throught the menu and change according to :



I just got this cannon eos ebel t5 and it came with one lens, and I'm getting this busy message and it won't take a picture.  I've done everything the manual says to do.  Sometimes it will flash the yellow light in front and make a beeping noise.  It still won't take a picture.  I have it in the modes the manual tells me to put it in.  Help!  I don't have another lens to put on it.

Hi Stargazer!


Thanks for reaching out, we're happy to help! Put your lens in manual focus mode (MF), and see if you can take a photo. If you can, that indicates that your lens is having a focusing issue. 


While in Manual Focus (MF), try to rotate the focus ring (not the zoom ring) on your lens all the way one direction, and then all the way the other. Once you've done that, flip the switch on the lens back to AF mode, and put the camera in "P" on the top dial and try to take another photo in a well-lit area to see if that resolves the issue.


If it doesn't, you'll want to contact our US-based support team for further troubleshooting. They're at 1-800-OK-CANON (800-652-2666) from 8am to Midnight (ET) during the week, or from 10am to 8pm (ET) on Saturdays. 


If you're outside of the US, you'll want to get in touch with Canon in your area by clicking HERE


We hope this helps!

My camera is also doing the same thing, it never has done this in the years that I have had it.  Suddenly a few weeks ago it started saying it was busy and would not focus and take picture.  I had to wait until the screen turned black then it would work again.  Now however even after the screen turns off it will just keep repeating that it is busy.  I am taking pictures indoors medium light (flash is on)  I took about 20 pictures then it just decided not to take the next picture, same light same basic picture.  In the past it has only done this when taking pictures in a lower light with the flash turned on and of a dressed mannequin against a white wall.  Mannequin is black and close are of various colors and patterns.

If you have a Class 10 card then you should have no problems.

However, if you do have the Class 10 card, try formatting it to clear all your old images and videos off of it.

There any one of several reasons why the "buSY" message might appear.  These reasons are described and explained in the full User Manual, which is available for download from your camera's Canon Product Support Page.  


Note, the full User Manual is NOT the highly abbreviated version that gets packaged with many cameras.  Reasons can range from incorrect or bad memory cards, built-in flash needing to recharge, low battery, noise reduction settings, etc.

"The right mouse button is your friend."

to me the problem started when i replaced my battery for a new one.

It seems those 2nd fake batteries are to blame

I am having the same problem with Canon EOS, Rebel T5i, using EFS 18-55mm lens that came with camera.  Getting a busy signal when using AF.  

When i first used the camera, it seemed to work fine.  

now 6 months later, it refuses to take some pictures.  it does seem to be having trouble locking in.

I have played around with different settings.  I first had a problem outside on a sunny day.  The images the camera did take were fuzzy.  I have been taking pictures all over the house in different lighting conditions.  It will take some picures, but refuses to focus in most conditions.

Try changing the dial from the green A+ to P.

I am having this same problem and am out of the country.  I am hoping I can fix this on my own.  My camera is a canon EOS rebel XTI and I have a tamron 18-270 lens.  I can take pictures in MF, but not in AF.  The camera was working fine until this afternoon, nothing happened to it.  Sometimes I get an error 99 message, but usually it just says busy and won't take the picture.  Any help is greatly appreciated.