cancel
Showing results for 
Search instead for 
Did you mean: 

EOS R6 issues w/ Tamron 24-70 G2

beastbeef
Occasional Contributor

So the first issue is that IBIS option doesn't show up when I use Tamron 24-70 G2, only "Digital IS" is available. IBIS shows up and works fine with my EF 50 and 100-400 L II (JUST CHECKED AGAIN DOESN'T WORK ON 100-400).

 

The second issue is the camera seems to "freeze" occasionally with Tamron attached, shutter, AF button wouldn't work but everything else does. Had to restart the camera to fix it.

 

Does anyone have any idea what's going on? 

5 REPLIES 5

Waddizzle
VIP

Are you using the Canon EF-RF mount adapter?  

 

People have been discovering that EF lenses are not fully compatible with IBIS.  It seems IBIS enters a degraded 2 or 3 axis mode with some lenses, or does not show in the menu at all with others.

------------------------------------------------------------------------------------------------

"Doctor told me to get out and walk, so I bought a Canon."

beastbeef
Occasional Contributor

Yes I am using the Canon EFEOSR adapter. Also I just checked again, IBIS only works on EF 50mm 1.8, not 100-400L II.

 

Is this something Canon intend to fix in the future? Coming from non-IBIS cameras I used to not having it, but still.


@beastbeef wrote:

Yes I am using the Canon EFEOSR adapter. Also I just checked again, IBIS only works on EF 50mm 1.8, not 100-400L II.

 

Is this something Canon intend to fix in the future? Coming from non-IBIS cameras I used to not having it, but still.


Fix?  There is nothing that needs to be fixed.  I'm not sure if Canon is still manufacturing many EF mount lenses.

 

C442A641-B7F1-4FC8-B005-E72E2BB8CA50.jpeg

 

I read the above to mean that the mount adapter is NOT designed to work with any and all EF mount lenses, including many Canon lenses.  As far as third party lenses, forget about it.  They're not supported by Canon.  That's on the third party.

------------------------------------------------------------------------------------------------

"Doctor told me to get out and walk, so I bought a Canon."

shadowsports
Esteemed Contributor

All true, and Tamron hasn't updated their FW for this lens in Canon mount:

 

TAMRON | Support

~Rick
Bay Area - CA
~6D2(v1.1.0) ~Many Lenses ~DxO PhotoLab Elite ~Windows10 Pro ~EVGA RTX 2080 FTW3 Ultra ~ImageClass MF644Cdw ~Pixel6

shawnphoto
Frequent Contributor

I like Tamron lenses, in fact, the second lens I ever bought for my Pentax *ist D back when I was a freshman in college was the Tamron 90mm Macro. I had so much fun with that lens. More recently I got a Tamron 70-200 G2, it was pretty good on the 6D II, and pretty good on the R most of the time, but in video mode it just went bonkers and would start making these loud screaching noises... LOL. It would do the same when viewing the output of the camera via the Canon Connect app that works with a phone. After a year of owning the R (two years total since it came out) Tamron never updated it. I wrote them and told them about it and they wanted me to send the lens in, but I opted against it because I needed the lens for weddings. End of the day I bought the Canon RF 70-200 and I am very happy with it. I sold the Tamron for close to $800 on eBay... There isn't a thing I miss about that Tamron compared to the Canon RF 70-200...