Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS R6 Mark II No connection with EOS Utility


Can somebody help me with a connection problem. My Canon R6 Mark ii doesn't communicate with Utility. I only get this message on my computer. The interface cable is connected to the camera and the computer and I want the program to just start so I can choose the files. 
Everything worked yesterday, but today it doesn't and I dont understand why?

Skärmbild 2023-12-07 143301.png



If you are going to connect via cable I suggest you just use the EOS3 app directly.

You can find it in the EOS Utility folder in the Applications folders.

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, Pixma TR8620a, LR Classic

I'm not quite sure I understand. I have been able to just put the cable in the camera and the Utility program starts directly. What EOS3 app is it? Something else than this icon? 👇🏼

Skärmbild 2023-12-07 145758.png

In the Applications folder find Canon Utilities and then EOS Utility and then EU3.

Select the EU3 icon to execute EOSU3 directly:

Screenshot 2023-12-07 at 9.18.01 AM.png

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, Pixma TR8620a, LR Classic

Rising Star
Rising Star

If something worked yesterday but not today then check to see what is different to yesterday from today.

  • Did you update the camera firmware? Sometimes new firmware needs an update to EOS Utility too
  • Have you changed the "Choose USB connection app" setting on setup menu 5? It should be photo import/remote control
  • Did you change the USB cable or the port it is plugged in to on your computer?
  • Have you installed a Windows update?

Go over these and see if you can get back to the working setting of yesterday


Brian - Canon specialist trainer, author and photographer
click here to view the press release