cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS R5 battery icon flashing, images not saving to memory cards

iloveridge
Apprentice

Hello, recently shooting with my new (3 months) R5 and battery was dying (flashing) but everything working as usual, however realised that the images weren't saving to either of the memory cards! Anyone else had this problem? Lost about 140 images. Schools and Wedding photographer so really can't risk images not saving!

Do I need to just change the battery before it fully drains, or is there an issue with the camera. 

Many thanks 

2 REPLIES 2

shadowsports
Legend
Legend

Greetings,

You can continue to shoot with a battery while the low battery indicator is flashing, but If you are trying to shoot bursts, things might slow down.  Could this be a buffer issue?  Are you using UHS-II v90 SD cards, and high quality CFExpress Type B cards with the camera?  I might shoot 20-50 shots on a low battery, but would switch out to a fresh one as soon as possible.  You don't want to fully exhaust a battery.  The other thing I recommend against is charging a battery fully, running it down to 50% then charging it to full again repeatedly.    This can decrease its life over time.  A 3 month old battery should be in good condition.  

Are you formatting your cards in camera before each shoot?  Sometimes using folders and non-standard naming conventions have caused the behavior you are describing.  I've not experienced this behavior before, but things like this do happen.  Usually however, there is an explanation.

~Rick
Bay Area - CA


~R5 C (1.0.7.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

Heya, Thanks for your response, It wasn't slowing down shooting at all which is why I didn't think anything of it until it was too late. Yes, have 2 cards in at a time, shooting raw to both - sandisks SD ultra 64GB and CFExpress extreme pro 128gb, which are formatted via camera before each shoot so should be alright surely?

They were showing in playback one minute, then simply not there the next! Considering already going back to my 1dxm2 for reliability. 

Will have to try changing battery before its flashing and see if it happens again.

Avatar
click here to view the gallery
Announcements