Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS 80D Getting error 70


I have tried using webcam utility software with my caon eos 80d, while connecting after few seconds it shows the error 70 and the camera stops working, i have tried removing battery and again starting the webcam utility but it again and again showing the same error.


Product Expert
Product Expert

Hi there,


Does the error 70 occur any other time? For example, if you were to record a movie for ten minutes with the camera on its own without a computer  does the error 70 happen as well?


You'll need to answer Mark's question.


If the error displays under normal use and shooting video, you have a more serious issue:



Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

I have an 80D, and mine will error out when used as a web cam as well, but I can shoot until my battery dies in any other function. Any thoughts?

Any shooting and recording are all OK.

But whenever I cast streaming via EOS Webcam utility, my 80d stops every 2~3 minutes with "Err 70".

I changed broadcasting software from OBS to many but same result always.

Help us please.


I am having the exact same issue.  I have done a few FB Lives with no problem, going on for well over an hour.  Attempted a FB live via my Canon 80D this week, and the camera shuts down after less than 2 minutes, and gives an Error 70.  Everything I see in Google searches are all related to shooting stills.  I can still shoot photos and I can shoot regular video with no problem.  Only when I try to go live through the EOS Utility that it gives this error, and always within the 2 minute mark.

Yup. Sounds about right.

Praying its an EOS Utility Beta issue.  I see that the full version has come out for the PC.  But I am on a Mac and it isnt up to full version yet.

I also have been recently having this problem. I have been using my 80D almost daily since April as a Webcam. I downloaded the new utility today and didn't see much difference. I shut off HD video and that seemed to help or delay the error. Maybe something is wearing out due to heat from being on so much? I never shot hours and hours of video before, mostly stills.

I am getting this error too after several minutes of using an 80D as a webcam (zoom) on os x 10.15  (ER 70, the have to remove battery).

Any solutions?