cancel
Showing results for 
Search instead for 
Did you mean: 

Canon RP

garth52
Occasional Contributor

I'm in the learning mode with the EOS RP I bought.  I'm attempting to use it for astrophotography.  I'm using a Pixel remote timer.  Timer works great when I have a lens attached to the camera.  The issue I'm having is when I connect the camera to a field flattener on my telescope, I can't seem to get the timer and camera to work together.  The timer clicks off the seconds, but the camera does nothing.  I checked the plugs and all, and no problem.  Put a lens on the camera, it works. Take the lens off and ust the t ring connect to put it back inline with the field flattener, and nothing.  What am I missing?  I have a EF control adapter ring on the RP so that I can use my EF lens.  Is there a setting, or what?

1 ACCEPTED SOLUTION

MikeSowsun
Respected Contributor

You need to go into the Custom Function menu and enable shutter release without lens.

 

6C6571C2-310F-433A-8D99-929D85C6195F.jpeg

 

2A08EA99-BADF-4924-8AEB-071699CE17C6.jpeg

Mike Sowsun
80D, 5D Mk III

View solution in original post

2 REPLIES 2

MikeSowsun
Respected Contributor

You need to go into the Custom Function menu and enable shutter release without lens.

 

6C6571C2-310F-433A-8D99-929D85C6195F.jpeg

 

2A08EA99-BADF-4924-8AEB-071699CE17C6.jpeg

Mike Sowsun
80D, 5D Mk III

garth52
Occasional Contributor

Thanks Mike.  The RP has way more versatilitiy and features than any camera that I've ever own. I suspected that it was a setting or something, but I didn't know where to  start looking.  Again, thank you very much.