Showing results for 
Search instead for 
Did you mean: 

Can’t connect to smartphone

New Contributor
I purchased a t6i for Xmas but I’m having trouble connecting to my iPhone 6 Plus with the Canon Connect app. I’ve completed the set up, enable, etc. with a password from encryption code. It worked the first time after I typed in the 8 digit number. However, now it no longer connects and ‘AES’ is listed as encryption key. When I try to connect to the camera WiFi it lists my camera nickname on my iPhone but after clicking it just says incorrect password. Camera says “connecting “. I did delete and reload the app but I’m having same problem. Very frustrating since it worked a few weeks ago. Any tips are appreciated.

Frequent Contributor

Clear current Wi-Fi settings:

  1. Yellow Tab #1 bottom row: open "Wi-Fi Function".
  2. Hit "Info" button.
  3. Clear Wi-Fi Settings.
  4. Confirm "yes".

Now when you get setup again the process is the same as before when you first set the camera up with Wi-Fi to your iPhone. Just make sure that you are either sharing the same Wi-Fi network with both the camera and phone, or having the camera broadcast its own SSID.


To reconnect in the future, just remember the following steps:

  1. Yellow Tab #1 bottom row: open "Wi-Fi Function".
  2. Activate the "Connect to Smartphone" function.
  3. Confirm that the "choose SET" function on the top row is for your iPhone.
  4. Hit the "Connect" button at the bottom of the screen.

Remember to always make sure the camera and phone are on the same Wi-Fi network. Oftentimes people have their phone automatically hook into their home Wi-Fi and get stuck reconnecting their phone to their camera if they originally did a "Camera Access Point Mode" connection instead of infrastructure during setup.

New Contributor
Thanks! I’ll try this.