cancel
Showing results for 
Search instead for 
Did you mean: 

5D Mark IV Freezing up

iris
Frequent Contributor

I received a brand new 5D MarkIV from my husband for Christmas...I've enjoyed using the full frame camera and lenses I've collected over the years that rightfullly should be on a full frame camera...

 

Several days ago while shooting and an event, the Camera FROZE..I mean suddenly the AF for the lens was dead and dark..the LD screen on the back was lit up and frozen with the camera setting sitting there..I tried to simply turn it all off an the on of switch had no effect.. After tryik several other buttons it became evident that EVERYTHing was frozen..So I treated it like a FROZEn computer screen, taking out the battery and sd card and waiting for a few moments, REinserted and all was well.  I totally forgot about it and treated it as a "One-off"    However, I was wrong..today it happened again..Very disturbing to have this kind of issue with such an expensive piece of equipment.

 

I have looke on YOu Tube and at various websites for answers..Apparently others have this problem...Any Answers that you Canon Pros know of??

 

What would you do?  Should I let Canon Fix It?  Should I insist on a new Camera?  YOu pros out there would you just ask to have your mony back?  NOt sure than can even happen?

22 REPLIES 22

Cgraham
New Contributor
The battery was non canon. When I first got the camera i had an older tameron lens... went up to the canon service center with it and the camera and was told to get the newer tameron lens because the firmware on the older lens wasn’t supported-so we purchased the new model. No issues all season with it. I’m thinking it’s the battery and am going to change it out. Next step is going back up to the center.

Cgraham
New Contributor
The battery was non canon. When I first got the camera i had an older tameron lens... went up to the canon service center with it and the camera and was told to get the newer tameron lens because the firmware on the older lens wasn’t supported-so we purchased the new model. No issues all season with it. I’m thinking it’s the battery and am going to change it out. Next step is going back up to the center.

I started having this problem when I added a Canon F4 L 70-200 to my collection, The body worked perfectly before that for years.  A few days before the freezing started, I also put on and used a Canon Flash for the first time.  No freezing occured then, but...  I also just upgraded to the latest firmware.  I have to think it is one of these three changes.  My bet is the firmware...