cancel
Showing results for 
Search instead for 
Did you mean: 

My Canon EFS 55-250m 4-5.6 is blured >> the 135 setting

Econprof79
Occasional Contributor

This is a relatively unused and new lens (2-3 years old) on my Canon Rebel T2i. Never been damaged. It will produce shape photos until about the 100mm to135mm range settings. Not above that and at 250mm it is a disaster.

 

I have tried to test for this problem by shooting using a tripod and 200 ASR, f8 setting with a 2 second and then 30 second timer. However, it remains fuzy. I have tried various subjects (backlight, full sun, shade, etc) all on a tripod with the same results. I have also tried to change the f stop to the extremes and the shoot time as well, all to no avail. Ditto for 400, 800, 1600 exposure settings

 

I have also tired the same routine as oultined above with the stablizer off and with manual focusing, but the problem persists.

 

I have not tried to lock the mirror but the lens should produce acceptable photos on a tripod at 150mm I have been told

 

So I am wondering if it is a defective lens or if this lens abover 135mm is useless.

 

Any comments welcome

 

Cheers

10 REPLIES 10

Econprof79
Occasional Contributor

I get it about dropping it. But the problem exisited prior to dropping it. So it looks like a BAD LENS. I suspect Canon will not step up to that issue but I will try a new lens which is exactly the same to see if the problem exists there

 

Do you have any recommendations on an cost effective auto focus lens comparable to the Cannon 55-250mm?

 

Thanks

 

FT