cancel
Showing results for 
Search instead for 
Did you mean: 

TS8220 Cannot scan "failed to open a connection to the device (-21345)" MacOS Catalina

circusboy
Occasional Contributor

Using MacOS Catalina (10.15.6) the TS8220 prints correctly, but attempting to scan gives "failed to open a connection to the device (-21345)". The TS8220 has current firmware (1.010), is in same room 3' from router and 8' from iMac, on same 2G network.The scanner previously worked before upgrade to Catalina.

  • Using MacOS System Preferences -> Printers & Scanners the "Print" connects and can open print queue and show supply levels etc.
  • The "Scan" Open Scanner gives the "failed to open a connection..." error.
  • I have tried both MacOS Image Capture and Canon IJ Scan Utility Lite.
    • MacOS gives the "failed..." error
    • IJ Scan gives "Cannot communicate with scanner..."
  • I do not have a USB cable long enough to connect directly (and need to use wifi scanning)

Suggestions what else to try or is there already a solution?? Thank you!

1 ACCEPTED SOLUTION

Hello.

 

Try the following adjustment to see if we can resolve this issue:

 

1.  Go to the Home menu or press the Home button.
2.  Select the Setup icon.  This icon looks like a gear.
3.  Select Device Settings.
4.  Select LAN Settings.
5.  Select Wi-Fi.
7.  Select Settings.
8.  Select Advanced.
9.  Select TCP/IP settings.
10. Select IPv6.  If you see a Yes or No question, choose Yes.
11. Select Enable/disable IPv6.
12. Choose Disable.

13. Once this has been done, turn the printer off and back on.

 

Next, close any applications that are open on the Mac and perform the following:

 

1.  Click the Apple and choose System Preferences.  Then open the Printer and Scanners menu.
2.  Highlight and delete any copies of the Canon Printer listed on the left by clicking the minus (-) sign.
3.  Click the plus (+) sign and look for an option that says "Add printer or scanner".  Click this option when you see it.
4.  In the next window, click Default on the upper left corner.  Wait a few moments, then highlight the Bonjour version of the printer.   

5.  Click Add at the bottom when it becomes available.

 

Once the printer has been added, try accessing the "scan" tab in system preferences and see if the scanner can be opened.  If the error persists, we would have to advise that you contact Apple to determine why the AirPrint scanner cannot be accessed, or scan from a different Mac/Windows computer or from an iOS/Android device with the Canon PRINT Inkjet/SELPHY app.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

View solution in original post

21 REPLIES 21

Hi ptetreault,

 

What model printer do you own?

 

 

 

 

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

Canon mg5320

need to link to OS big sur