Showing results for 
Show  only  | Search instead for 
Did you mean: 



Dear Everyone,

I get this annoying error messages during scanning of documents with TS6220 printer. I have searched everywhere and can't find anywhere that the solution is posted. 


The printer is very near my ATT Router in the house.

I have installed the MD driver - md_win-ts6200-1_02-ea34.exe.


Sooo, we can't use the scanning feature of this printer. 


My connection is a wireless one and I can print documents with no problem at all and so this cannot be a network issue.


For quite sometime I have been using HP Photosmart Series but recently I ran into the problem of Printer Cartridge issues which HP does not have a solution for and I got upset and decided to switch to Canon Printer and once again a problem with scanning.


Please kindly help.



This is also the case with the Canon TS 5300 series.  I'm using Win 10 on a Dell with McAfee.  Turned off the VPN and still get the exact issues you describe above.  I can only get the Windows Scan utility to work with a hard wire USB connection to the printer; doesn't even see the scanner over the LAN.  All very frustrating, as this used to work at one time.


Same with G7020 printer (on windows 11). Sometime during scan, I get error. I turn off antivirus; I turn off vpn; But still error.

Cannot communicate with scanner. Possible reasons:
(Yes it is on, it is well connected, security software not interfering, scanner selected)

The only solution has been using Microsoft WIA drivers, except these are so much more limited -- but they work while Canon drivers crash. WIA drivers not worried about security software interfering. So it must not be windows problem or network problem, but Canon driver software problem.

How about fixing the driver bugs?



Not sure why, but I read somewhere that the WIFI signal strength below 60% is not good enough for scanning. Printing still works fine, but scanning would always result in ERROR CODE 2,157,50

I got the signal up to 80% but it still would not work. I turned off some electronics near my router and the scanning worked again! 

I found out it was my sub woofer below the router causing some interference. It was very weird as all my other wifi equipment had no problem.

Hope it helps.