cancel
Showing results for 
Search instead for 
Did you mean: 

MX922 scanner problem message: set the pc to start scanning

Denise
New Contributor

I am trying to scan using my MX922 printer.  I am getting a message: "set the pc to start scanning." Can't find what this means.

88 REPLIES 88

Tweetie
New Contributor

Thehib's comment was very helpful, and reminded me of something even more basic that I'd forgotten to do -- plug the scanner into my laptop! Hmmmm, with a red face, I submit it, in case anyone else was in such a hurry they also forgot! 😞

varice
Occasional Contributor

I ran into this... Suddenly the scan function from the Canon didn't work, I just got "Set the pc to start scanning."  WT??? Why work all this time and suddenly not?  Under scan>save/forward>select pc, only "local (usb)" appeared. No pc.  Yet the wireless connectivity was there (I checked, under WLAN set up).  Plus, I could print wirelessly, and could scan wirelessly if I initiated the scan from the computer via Canon utilities.  So it suddenly no longer could find the pc to scan from the unit, even though clearly the wireless connection was there.  Turned it on and off several times as suggested by another post.  Finally I went to Canon Utilities,> IJ Network Scanner Selector EX > Scan from Operation Panel Settings (button was already selected) > MX920 series already had box checked, so just said ok.  i.e. I didn't change a thing, but somehow that got it to work again, and I can now go back to scanning via the unit itself, specifically Scan button > Start on the MX922, instead of having to initiate the scan from the computer.  Hope this makes sense!

thehlb
New Contributor

I suddenly had this problem again as well, after a recent re-install, and turning it off and resetting didn't to the trick anymore. Varice's solution worked perfectly!! Thanks so much!

varice
Occasional Contributor

Glad it worked for you.  Also -- I have to do this periodically, I think it's related to power outages.  i.e. if the power goes out, even momentarily, you get the scolding little message from the printer that you didn't turn it off properly before disconnecting power (duh).  So then, even though it shows my computer on the top part of the printer's window, it shows only "Local USB" as an option for scanning something to.  I have to repeat the utilities process.

To clarify earlier directios, the application you're looking for is CNMNSST, so it's:

Canon Utilities,> IJ Network Scanner Selector EX > CNMNSST>Scan from Operation Panel Settings (button was already selected) > MX920 series already had box checked, so just said ok.  In my case no settings were changed, just doing it and saying ok to what was already selected seemed to somehow refresh it.

I had this problem appear after I turned off a lot of the autorun and startup programs on my PC to speed up its boot time.  I started IJ Network Scanner Selector EX as per verice's suggestion, and then the printer could see my PC instead of just the "Local (USB)" entry.  When I closed the IJ Network Scanner Selector EX program, it stayed minimized as an icon in the systray.  I checked and the printer could still see my PC.  However, I right clicked on the icon in the systray, and selected Exit to quit the IJ Network Scanner Selector EX entirely, and then - POOF - the printer could no longer see my PC.  So I started IJ Network Scanner Selector EX again, and - WHA-LA! - my PC showed up again on the printer.  Thus it appears, at least in my case, that having this program running at all times is necessary for that functionality.  When I first installed the printer this wasn't necessary, but apparently I tweaked something and now it is. So there's a right way to fix it, I am sure, but - kludge warning - I just added the IJ Network Scanner Selector EX program to my Startup folder so it runs each time I start my computer.  To do that, I made a shortcut of C:\Program Files (x86)\Canon\IJ Network Scanner Selector EX\CNMNSST.exe and put it in my personal accounts Startup folder: C:\Users\Derek\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup\CNMNSST.exe - Shortcut.  I know there's a better way and this is a hack, but it works for now.

I am having the same problem and am going bat-crazy trying to figure out how to resolve it.

 

Here's some background:

 

  • I'm running on a new 27" 4K iMac which replaced a 2009 iMac
  • It is running Yosemite, 10.10.5
  • I transferred all previous files, applications, settings from my old Mac
  • My new Mac has a new/different name
  • I was relatively easy able to get the computer to print over the network
  • The LCD display for PC now says Local (USB)
  • I have downloaded the latest drivers, I have turned the printer on and off multiple times
  • I have also turned the cable modem and router off and on
  • When I click scan from the printer the display says"Set the PC to start scanning"
  • I was just able to scan over the network using the Cannon IJ Scan Utility (which surprised me), but still same message from the printer as the USB option still displays

 

Any suggestions on how to get the display off of the local mode and show the network computer?  I have the original install CD, should I re-install?  Thanks in advance for any tips

Hi Skormy -- I don't have a Mac so I can't help you, but hopefully someone else chimes in.  Perhaps a re-install from the original CD would make the difference, if no one has any better ideas.

As a follow-up, I did wind up re-installing the software and everything seems to work.  It was pretty the last thing I could think of to do.

Glad it worked for you. 🙂

Thanks, dddderek - I did this and it worked!  When I pressed SAVE/FORWARD on the MX925 it could see my Mac again.  Thanks again.