cancel
Showing results for 
Search instead for 
Did you mean: 

Computer not detected by Pixma MG5650 for scanning purposes

FlowerP
New Contributor

Hello,

 

My Pixma MG 5650 connects fine to my computer for pritinting but when I try to scan, my computer can't be found by it.

I have installed the Canon IJScanner14f on my Mac OS10.15.7 Catalina then when it didn't work I completely deleted it with the Go>Library method, restarted the computer, reinstalled the driver from scratch, but the app has no interface (it doesn't seem to open at all) and the scanner can't find it.

 

Do you have any advice please?

9 REPLIES 9

Patrick
Product Expert
Product Expert

Hi FlowerP,

 

Please follow these steps:

 

1.  Click on the Apple in the upper left corner and then System Preferences.

 

2.  Click on Printers & Scanners.

 

3.  Click on the Canon MG5600 on the left side and then [-] at the bottom.

 

4.  Repeat until all are removed.

 

5.  Click the [+] at the bottom and then click on Add printer or scanner.

 

6.  In the add window, click one time on the MG5600 listing that is "IJ Network".

 

7.  At the bottom, next to "Use", please select the Canon MG5600 series and not Airprint or Secure Airprint.

 

8.  Click the Add button.

 

Back in the printers window, click one time on the Canon printer on the left and then click Scan on the right.

 

Are you able to scan?  If not, what error code appears?

 

 

 

 

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

I tried these instructions. When I selected the IJ Network listing no scanning button appeared anywhere. With the 'bonjour multiface' alternative, there was a scanning button. And if I hit that scan button, the same error message pops up. 

The application “Canon IJScanner14f” can’t be opened.

What should I do next?

Hi rangeley,

 

Please install the IJ Network listing as described above.

 

Once that is installed, please visit the Support Page of the PIXMA MG5600 series to download and install the IJ Scan Utility2:

 

https://www.usa.canon.com/internet/portal/us/home/support/details/printers/inkjet-multifunction/mg-s...

 

 

When that application is installed, please use it to scan.  For informaiton on using the IJ Scan Utility, please use the following link:

 

https://ij.manual.canon/ij/webmanual/ScanUtility/M/MG5600%20series/2.0/EN/SU/Top.html

 

 

 

 

 

 

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

Hi! I am having a similar problem except it's telling me "You do not have permission to open the application “Canon IJScanner14f”."

 

I get this message both when I try to "Open Scanner" from System Preferences, and when I try to run the Canon IJ Scan Utility2 app.

 

The only Canon IJScanner14f "app" I can find is what appears in the Libary/Image Capture/Devices folder, and I've made sure to myself (and everyone, just to cover my bases!) Read & Write permissions... when I saw this wasn't the default (everyone had only Read permissions) I was sure that changing this would solve my problem, but it didn't.

 

I'm able to print wirelessly, so the wifi connection is in order.

 

I've got a Pixma MG7520 that's admittedly 5+ years old and am on a MacBook Pro running Big Sur 11.5.

 

Any help you can send my way is appreciated!

Hello Amcalonder,

 

If you are getting that error, you can click on the apple in the upper left hand corner of the screen and then click on system preferences. Once in system preferences click on Security and privacy. In the general tab, make sure it is set to use apps from the app store and identified developers.

 

If you still get the same error, you can try going into printers and scanners and removing all connections for the MG7520 using the - at the bottom of the list. Once the connections are gone, you can click the + at the bottom of the list to add a printer. In the add printer window, you can select the option for the Bonjour multifunction and then you can click add.

 

In printer's and scanners, you can highlight the new scanner connection and then you can click the scan tab at the top of the window. You can click the option to open the scanner and you can try scanning from the window that comes up.

pstu
New Contributor

I'm having the same problem here with a MG7520.  Deleted all the printer connections and then added back one MG7500 series. Have checked the security preferences, and it is set to allow all Apple and identified developers.

 

I am in the admin account, yet it still says I don't have permission to open the IJ Scanner. And after a minute I get the message "Failed to open a connection to the device (-21345)" despite having just printed a document minutes before.

Thank you for your reply. In the time between posting this and getting the first reply I called the Canon assistance phone line and one of your colleagues walked me through solving the problem.

To be honest I don't remember how it was solved. However I would reccomend the assistance line to anyone with this problem (if they are ready to wait the ~20 minutes it takes to get an operator): the operator was very patient, knowledgeable and it was an easy way to have the problem taken care of.

mkli
New Contributor
  1. Quit any apps that are open.
  2. From the menu bar in the Finder, choose Go > Go to Folder.
  3. Type /Library/Image Capture/Devices, then press Return.
  4. In the window that opens, double-click the app named in the error message. It's the name of your scanner driver. Nothing should happen when you open it.
  5. Close the window and open the app you were using to scan. A new scan should proceed normally. If you later choose to scan from a different app and get the same error, repeat these steps.

    It works for me !

https://www.macrumors.com/2021/08/14/apple-to-fix-scanner-permission-error-on-mac/

pstu
New Contributor

That worked! Thank you so much. The warning to pick the correct app named in the error message is important. I first selected the highest-numbered version (15), but it was the version IJScanner14 that was the right one. Now scanning again. Thank you!