cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon ScanGear configuration under Linux

nilli
Contributor

Hello !

 

I am using my Canon MG5300 printer with ScanGearMP and Linux Mint.

 

Unfortunately the ScanGear window opens in an unusefull shape every time I open it.

Also the configuration of the settings need to be repeated every time I start it.

 

How could I modify windowsize and setting defaults ? Coudl I start scangearmp with -options ?

 

Thanks so much for your support !

 

 

3 REPLIES 3

shadowsports
Elite

Greetings,

ScanGear MP v1.80 was released over 9 yrs ago.  I would not count on it to run under Mint Distro.

 

Start here, but your questions goes beyond the scope of the Canon forum.

 

Happy Holidays

 

 

~Rick
Bay Area - CA


~R5 C (1.0.2.1) ~RF Trinity, ~RF 100~400, +Canon Control Ring

~6D2 (v1.1.1) Retiring ~EF Trinity, others ~DxO PhotoLab Elite ~Windows10/11 Pro ~EVGA RTX 3080Ti FTW3 Ultra ~ImageClass MF644Cdw ~Pixel6 ~CarePaks Are Worth It

Hello Rick,

 

thanks for the answer, sorry I did not make my intention clear.

 

As Win7 will not be supported any more in Jan. 2020 and Win10 is not an option for me I started using Linux Mint.

 

But I don't want to scrap my Canon pinter, with wich I am quite happy, just because of the switch to Linux.

 

Therefore I am woundering if there is any documentation about the ScanGear MP v1.80 driver.

 

Are there any options that I could start scangearmp with ?

 

Happy New Year 2020 !!

The following process worked for me. First, let me hasten to say I am by no means a Linux guru. So, forgive me if my description lacks the presion of terminology that those proficient in Linux are used to.

 

After downloading (from Canon), unpacking and installing the Debian printer and scanner drivers for my Maxify MB 5120 in Lunix Mint 19.3 Cinamon, I found that the printer side worked fine but that the scanner was not showing up in Simple Scan. This is a commonly reported problem. I should add that this Canon MFP is directly connected to my my router, not a direct USB connection to the computer. So it is a "networked" device.

 

After researching this issue and trying different suggested fixes the involved terminal commands and script edits that did not work, I went back to Downloads and exectuted the scanner installer again. Mint makes this easy by just a double click with the mouse, like Windows. This time, however, I got a message popup saying the package was broken and that I needed to fix it with Synaptic. There were a couple of terminal scripts given to facilitate this but the long and short of that was I just needed to open Synaptic Package Manager and execute the "Fix Broken Packages" tool found in the "Edit" tab of the Synaptic PM GUI. 

 

Once the broken package was fixed, if I recall correctly, I typed in "scangear" and Snaptic fetched the Scangear driver driver package and you could see the list of Canon MFP models it covered. I clicked on the box for my MFP model which then generated a popup asking permission to install all related "dependencies" for which I gave approval. I clicked on "Apply" and Synpatic did the rest. After that processed was finished the scanner showed up in Simple Scan and I was able to scan without issue.

 

In retrospect, I'm not sure that I didn't create the "broken package" problem with all my other attempts to fix the issue. I have a hunch that the real fix was just to going to Synaptic Package Manager, seaching for the scangear driver, satisfying the dependencies and checking the box for my model.

 

Hope this helps someone.scangear.png

Announcements
11/22/2022: New firmware available for EOS R3, EOS R7 and EOS R10
11/16/2022: We're thrilled to be ranked among the Best Employers for Veterans in 2022 by Forbes.
10/14/2022: Help ensure your autofocus is properly aligned with a Canon Precision Alignment
09/19/2022: New firmware version 1.0.4.1 is available for EOS C70
08/31/2022: New firmware version 1.1.1 is available for RF 70-200mm L IS USM
08/09/2022: New firmware version 1.2.0 is available for CR-N 300
08/09/2022: New firmware version 1.2.0 is available for CR-N 500
07/28/2022: New firmware version 1.2.1 is available for EOS-R3
07/21/2022: New firmware version 1.6.0 is available for EOS-R5
07/21/2022: New firmware version 1.6.0 is available for EOS-R6
07/21/2022: New firmware version 1.1.0 is available for EOS-R7
07/21/2022: New firmware version 1.1.0 is available for EOS-R10
07/14/2022: New firmware version 1.0.1 is available for CR-X300
07/01/2022: New firmware version 1.3.0 is available for PowerShot PICK
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
06/07/2022: New firmware version 1.0.3 is available for EOS M50 Mark II
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version 1.0.5.1 is available for EOS-C500 Mark II
05/26/2022: New firmware version 1.0.3.1 is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version 1.0.1.1 is available for EOS R5 C
03/23/2022: New firmware version 1.0.3.1 is available for EOS-C70
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/19/2022: READY FOR ANYTHING EOS-R5 C
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.
01/05/2022: Welcome to CES 2022!