Showing results for 
Search instead for 
Did you mean: 

Canon MX922 having issuing printing text

New Contributor

My Canon MX922 prints images without any issues, but text does not print properly.  I have removed the print head and cleaned it, ran head alignments, replaced ink cartridges, updated the drivers and the firmware, and even disabled the advanced printing features. Still not getting it to print text properly.  If I print the same text in different fonts, the issues change.  Here's an example of the same file printed in 3 different fonts  (There should be no bold text on this file) :








I'm thinking maybe it is a driver or firmware issue or a recent Windows 10 update.  I've alreay installed all of the Recommended and Optional drivers on Cannon's website for this model, but the latest Recommended Driver is from January 2016.  Any help with this issue would be greatly appreciated. 


Thank you!


Esteemed Contributor


Its not a driver, firmware issue or a recent Windows 10 update...


This is caused by a clogged or malfunctioning printhead.  


Try printing a nozzle test pattern.  I know you tried to clean it, but I'll bet thats the issue.

Bay Area - CA
~6D2(v1.1.0) ~Many Lenses ~DxO PhotoLab Elite ~Windows10 Pro ~EVGA RTX 2080 FTW3 Ultra ~ImageClass MF644Cdw ~Pixel6

Hi Rick,


Thanks for your help with this.  Here is the Nozzle Check Pattern that printed:


Let me know what you think.

Thanks again for your help.


I recommend you contact Canon support at 1-800-OK-CANON (1-800-652-2666), Monday - Friday, 8:00 AM - 8:00 PM EST excluding holidays.


You will need to have a Canon account when you call. If you have not created account, please click HERE: