cancel
Showing results for 
Search instead for 
Did you mean: 

EOS 80D WiFi Connection issue

ikovalyov
Occasional Contributor

Hi.

Really need help with my issue.

I connected with my camera to the wifi (EOS Utility mode). Router lists this device as connected. But EOS Utility not showing this device in list so I can't connect Camera to PC.

Any help would be appreciated.

Thanks.

1 ACCEPTED SOLUTION

I solved my issue by enabling network discovery in 

 

Control Panel\Network and Internet\Network and Sharing Center\Advanced sharing settings

 

 

80D

View solution in original post

45 REPLIES 45

richrd0001
Occasional Contributor

I found that the smaller "pairiing" window that pops up can sit there for 10-25 seconds before your camera name appears. 

 

I was having a problem with EOS Utility after I managed to make a connection on my desktop (Windows 7).  I could see that my camera was recognized as a wireless connection (just like my router connecting me to my ISP) but I couldn't get EOS Utility to do anything but show me the "pair devices" screen.  I'd exit the utility and restart but always the same thing. 

 

Finally, I unintalled EOS Utility and reinstalled it an that solved the problem. Now, with the connection established, when I re-launch EOS Utility I get the main screen which allows me to transfer my files.

richrd0001
Occasional Contributor

A further note on my post.  I found that the problem with EOS Utility not going past the initial "pairing" window can be solved by using Windows Task Manager.  The utility program on my Windows 7 computer did not remove itself from the list of active processes when I successfully made the connection.  By using Task Manager I could stop the process and force the program to unload from memory.  Merely clicking on the shortcut after doing this lauches the Utility and it then senses the active connection and goes to the download files screen.

 

It is not necessary to uninstall the program and reinstall it.

I am having the same problem.

 

I can not connect my brand new (bought yesterday) Canon 80D via the EOS Utility to my Windows 10 PC; event after exiting the EOS Utility software via task manager and restarting, or after rebooting.

 

On the camera the message 'Wi-Fi on' appears in the display - and when I go thru the setup screens on the camera they correctly identify the SID of my home network - as well as an IP address for the camera.

 

However, when running EOS Utility Launcher I see a picture of a camera with at grey line to picture of a computer.  If I click on the 'Pairing over Wi-F/LAN' button and another window opens up entitled 'EOS Paring Software' - but there are no devices listed under Camera model, MAC address, IP address.

 

I have also tried turning off my firewall, and running the Canon app on my PC as an administrator - neither helped.

 

I can, however, ping my Canon 80D from my PC (via the command prompt) - so I know, at least, the PC can at least 'see' the Camera from that perspective. 

 

Any further helps or clues would be appreciated.


Thanks, Rob

 

 


@RobLatour wrote:

I am having the same problem.

 

I can not connect my brand new (bought yesterday) Canon 80D via the EOS Utility to my Windows 10 PC; event after exiting the EOS Utility software via task manager and restarting, or after rebooting.

 

On the camera the message 'Wi-Fi on' appears in the display - and when I go thru the setup screens on the camera they correctly identify the SID of my home network - as well as an IP address for the camera.

 

However, when running EOS Utility Launcher I see a picture of a camera with at grey line to picture of a computer.  If I click on the 'Pairing over Wi-F/LAN' button and another window opens up entitled 'EOS Paring Software' - but there are no devices listed under Camera model, MAC address, IP address.

 

I have also tried turning off my firewall, and running the Canon app on my PC as an administrator - neither helped.

 

I can, however, ping my Canon 80D from my PC (via the command prompt) - so I know, at least, the PC can at least 'see' the Camera from that perspective. 

 

Any further helps or clues would be appreciated.


Thanks, Rob

 


Be sure you're using the latest version of EOSU. Note that a new version appeared on Canon's Web site last week.

Bob
Philadelphia, Pennsylvania USA

richrd0001
Occasional Contributor

I think one step that needs to be emphasized is that once the camera is recognized as a network device, one must actively select that network device in Windows's list of network connections and connect to it.  You are NOT connecting to your camera THROUGH your regular network (the one you use to connect to the web so you can browse your news blogs, etc.).  The camera is a separate network and must be connected to (which will disconnect you from your "regular" network).

Thus, I think this is the sequence to follow to make a successful EOS 80D wireless connection (wifi on camera off but previous connection successfully made).  I don't think the running processes of EOS Utility need to be killed if you've launched the utility.  What is crucial is that WINDOWS sees your camera network AND you have connected to that device (your camera):

 

1. Click on the "bars" icon at the bottom (or right) of Windows taskbar. Your "regular" network should be listed but not your camera network.

 

Bars.JPG

 

2. EOS Utility is unloaded or unloaded.

3. Turn on EOS 80D.

4. Press "Menu."

5. Go to "Utility [wrench], page 1.

6. Select "Wireless communication settings."

7. Wi-Fi/NFC selection at top reads "Disable."  Select. this option.

8. Select "Enable."

9. Select "SET OK."

10. On next page Wi-Fi/NFC selection at top reads "Enable."  

11. Select "Wi-Fi function."

12. Select top right icon [computer monitor and keyboard].

13. Next page for me says at top line "Choose set. SET2."  I must have selected this set in the process of pairing my camera.  I don't understand the purpose of "set."

14. Select "connect."

15. Next window is "Remote control (EOS Utility)."

16. Select "OK."

17. Select "Menu."

18. Press "INFO." button once.  I happen to have the Scene Intelligent Auto" option selected with the Mode button.  At the bottom of the screen that appears this is indicated and at the bottom of the screen is a flashing icon (flashing icon means "waiting for reconnection").  This indicates that wifi is on. (The LCD panel will also say "Wi-Fi On,")

19. On your computer, click on the "bars" symbol. Your "regular" network, your "camera" network, and you neighbors' networks appear in this list.  If you don't see your camera network click on the "refresh" icon top right or just wait for a few moments. At this moment, my camera network (EOS80D-155_Canon0A) is appearing and disappearing even though the camera is right next to the computer.  Other neworks are doing the same and I don't know why.  My regular network does not do this, possibly because the computer is connected to it. Hit "INFO." again until you see the blinking "Wf-Fi" icon.

20. On the list of neworks select your camera network and click on "connect."

21. EOS Utility 3 screen appears titled "EOS 80D."  This enables me to download, etc.

 

I forget if I had EOS Utility running when I turned on my camera's wifi.  To be sure this still works if you turn on wifi at your camera without first launching EOS Utility, I quit the utility and killed the running process.  Then I relaunched the utility.  Windows automatically reconnected to the camera network. The EOS Utility screen that first appeared was the "Connect a device" screen but after 10 or 15 secs. that screen disappeared and the screen described in 21 above appeared.

 

Thus, I was incorrect that EOS Utility needs to be uninstalled or that it needs to be unloaded from memory as an active process.

 

I hope this is useful.

 

The Canon manual on Wireless function leaves much to be desired in my mind.  Once you understand how to do it, the manual is clear.  At the outset it was quite bewildering to me. 

 

PS - The "Enable" language in Step 7 is confusing.  When the connection is disabled you see the word "Enable."  be "Enabled" instead.  When I disable the connection the resulting message is "Disable" which I just DID already.

richrd0001: Thank you for your detailed post.  That helped me connect to my camera - I could not have done it without you.  I agree the Canon manual on Wireless function leaves much to be desired!  Very Best Regards, Rob

 

richrd0001
Occasional Contributor

Your welcome, Sir. I have a few more grey hairs after trying to make sense of the manual.  Glad it helped. 

ikovalyov
Occasional Contributor
Hi.
I have home PC connected to the local network via router. Also I can connect to the same network via wifi.

It looks like few months after I had this issue it appeared to be resolved when I tryed.

Connect to PC -> manual settings -> selected existing network -> connected.

Windows sent me notification if found eos camera and suggested to start pairing,

That;s all.. not more issues 🙂

richrd0001
Occasional Contributor

Thank you.  Where can I find the "Connect to PC" option?

ikovalyov
Occasional Contributor
remote control (eos utility)