cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon connect app Wi-Fi problems with Google pixels

5150Jim
Apprentice

I have talked to Google two different times the last couple of days trying to get the problem resolved that everyone is having with the Canon connect app will not finish setup with the Wi-Fi anymore. After a year of using it it just stopped working

I have spoke to Google and they keep saying it's a manufacturer's problem. When really it's Google's problem

I hope everyone that's having an issue will contact Google until someone finally gets to the right person that can look into this and correct it on our phones

3 REPLIES 3

shadowsports
Legend
Legend

Greetings,

I'd like to agree with you, but I am not having the issue that many here have posted about.

Formally Pixel4, Pixel6, currently Pixel 8

Former body 6D mkII

Currently Body R5 C

My phones running Canon Connect were / are able to connect to my camera(s) 100% of the time.

I no longer have my 6D2, P4 or P6.  

I did report this issue to Canon for investigation.  Can you please provide the model of your camera please? 

Can you confirm that the behavior is as follows:

Bluetooth connections are successful, but when you try to initiate a Wi-Fi connection to (for example) transfer images the connection fails when you try to enter the password for the camera's Wi-Fi broadcast?

Thanks

~Rick
Bay Area - CA


~R5 C (1.0.6.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

Bluetooth connections are successful, but when you try to initiate a Wi-Fi connection to (for example) transfer images the connection fails when you try to enter the password for the camera's Wi-Fi broadcast

Yes... That is what is happening

And I did Search - Canon Community
https://community.usa.canon.com/t5/forums/searchpage/tab/message?advanced=false&allow_punctuation=fa...

And there is many people having the same problem with Pixel 6 & 7

 

Zander013
Contributor

im having the same issue i think it has to do with an update by pixel but because canon hasnt updated the app since august 23 according to my app store. i think its due to an issue between the wifi on the camera and the phone not wanting to talk properly but its something canon needs to get fixed on their end but probably wont soon if at all.

National Parks Week Sweepstakes style=

Enter for a chance to win!

April 20th-28th
Announcements